Project

Profile

Help

Bug #1435

Internal error on map-pairs

Added by Michael Kay over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XPath conformance
Sprint/Milestone:
-
Start date:
2012-03-08
Due date:
% Done:

0%

Estimated time:
Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:

Description

I know XQuery 3.0 is a work in progress, but thought I’d flag this up. Using latest Stylus Studio that comes with Saxon 9.3.0.8, if I try

map-pairs(concat(?,?),1 to 10, 2 to 11)

I get:

Internal error: early evaluation of subexpression with no context

Works fine on BaseX 7.1.1

map-pairs(function($a,$b){concat($a,$b)},1 to 10, 2 to 11)

works ok on 9.3.0.8

map(max(?),1 to 10)

fails too (Pointless I know, just want to show error with simpler case).

History

#1 Updated by Community Admin over 9 years ago

Thanks for reporting it. Both the problem queries work fine in 9.4 (tested on 9.4.0.3). I suspect the problem is that the (?) syntax for partial application was fairly new when 9.3 was released, and Saxon translated it to the earlier partial-apply() function, which didn't handle the case where all of the arguments were left as place-holders.

Since this is a corner case and the problem isn't present in the current release, I propose not to fix it in the 9.3 branch.

#2 Updated by Michael Kay over 9 years ago

  • Status changed from New to Resolved
  • Found in version changed from 9.4 to 9.3

#3 Updated by Michael Kay over 8 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 9.4

Please register to edit this issue

Also available in: Atom PDF