Project

Profile

Help

Bug #1800

format-dateTime - Ignored padding given the picture with width for roman numerals

Added by O'Neil Delpratt over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Category:
XPath conformance
Sprint/Milestone:
-
Start date:
2013-06-12
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:
Platforms:

Description

For the the test case:

 format-dateTime(xs:dateTime('1004-01-01T12:00:00'), '[Yi,4-4]')

The padding has been ignored in the output of the result, which should be @'miv '@.

History

#1 Updated by O'Neil Delpratt over 8 years ago

  • Status changed from In Progress to Resolved

In the class FormatDate when outputting roman numerals we were ignoring the width specifier. This has now been fixed and committed to subversion. (We still ignore the min, but pad with spaces if necessary up to the max width.)

#2 Updated by Michael Kay over 8 years ago

  • Category changed from XQuery conformance to XPath conformance

Note: the problem is also present in 9.4, but we are not patching 9.4 in the interests of stability.

#3 Updated by O'Neil Delpratt over 8 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.5.1.1

Bug now closed. Applied to the Saxon 9.5.1.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF