Project

Profile

Help

Bug #1817

closed

Element output with incorrect prefix (bytecode only)

Added by O'Neil Delpratt about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Low
Category:
Byte code generation
Sprint/Milestone:
-
Start date:
2013-06-20
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:
Platforms:

Description

For the element

 a:a ns a:= http://example.com/A and element b:a ns b:= http://example.com/A

These are considered as equal at the bytecode level.

Actions #1

Updated by O'Neil Delpratt about 9 years ago

  • Description updated (diff)
  • Status changed from New to Resolved

Bug fixed in 9.5 and committed to subversion

Actions #2

Updated by Michael Kay about 9 years ago

More specifically the issue is that Saxon generates bytecode containing the required node-names as static variables. When generating static variables, it eliminates duplicates, and the name objects representing two QNames are considered duplicates if they have the same local name and URI, even if the prefixes are different. Currently a stronger test is used for atomic values (so for example the integer 3 and the decimal 3.0 are not considered duplicates); the fix for this problem introduces a stronger test also for NodeName objects.

Actions #3

Updated by O'Neil Delpratt about 9 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.5.1.1

Bug now closed. Applied to the Saxon 9.5.1.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF