Project

Profile

Help

Bug #2199

NullPointerException thrown in DotNetDomBuilder

Added by O'Neil Delpratt almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
.NET API
Sprint/Milestone:
-
Start date:
2014-10-28
Due date:
% Done:

0%

Estimated time:
Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:
Platforms:

Description

Bug issue reported by Joseph Crowther:

The following exception is thrown in .NET ONLY when building a DOM document from a XSLT transform:

java.lang.NullPointerException
	at cli.System.Xml.XmlNode.Normalize(XmlNode.cs:642)
	at net.sf.saxon.dotnet.DotNetDomBuilder.endElement(DotNetDomBuilder.java:168)
	at net.sf.saxon.event.NamespaceReducer.endElement(NamespaceReducer.java:202)
	at net.sf.saxon.event.ComplexContentOutputter.endElement(ComplexContentOutputter.java:450)
	at net.sf.saxon.expr.instruct.ElementCreator.processLeavingTail(ElementCreator.java:270)
	at net.sf.saxon.expr.instruct.ElementCreator.processLeavingTail(ElementCreator.java:254)
	at net.sf.saxon.expr.instruct.Block.processLeavingTail(Block.java:611)
	at net.sf.saxon.expr.instruct.Template.applyLeavingTail(Template.java:211)
	at net.sf.saxon.trans.Mode.applyTemplates(Mode.java:949)
	at net.sf.saxon.expr.instruct.ApplyTemplates.apply(ApplyTemplates.java)
	at net.sf.saxon.Controller.transform(Controller.java:1707)
	at cli.Saxon.Api.XsltTransformer.Run(Unknown Source)
	at cli.TestSaxon.Program.TransformXmlDocumentUsingSaxon(Program.cs:55)
	at cli.TestSaxon.Program.Main(Program.cs:14)

History

#1 Updated by O'Neil Delpratt almost 7 years ago

  • Status changed from In Progress to Resolved

The problem is the PipelineConfiguration object is called before being initialised. This object is an attribute in the DotNetDomBuilder class used in the DOMDestination.

Big fixed on the Saxon 9.5, 9.6 and 9.7 svn branches.

#2 Updated by O'Neil Delpratt almost 7 years ago

Bug fix applied to the Saxon maintenance release 9.5.1.8.

Saxon 9.6 maintenance release is pending.

#3 Updated by O'Neil Delpratt almost 7 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 9.6.0.2

Bug fix applied in the Saxon 9.6.0.2 maintenance release.

#4 Updated by O'Neil Delpratt almost 7 years ago

  • Fixed in version changed from 9.6.0.2 to 9.5.1.8

Please register to edit this issue

Also available in: Atom PDF