Project

Profile

Help

Bug #3113

XQuery update not supported in Saxon/C

Added by O'Neil Delpratt over 3 years ago. Updated over 1 year ago.

Status:
In Progress
Priority:
Normal
Category:
Saxon-C Internals
Start date:
2017-01-23
Due date:
% Done:

0%

Estimated time:
Found in version:
1.0.2
Fixed in version:

Description

Reported by node.js user:

XQuery update functionality is currently not supported in Saxon/C. The underlying code base to support XQuery update feature are all there, but there needs to be some addition API in the Saxon/C code to make it work.

As a workaround it should be possible to do XQuery update by setting the configuration property:

http://saxon.sf.net/feature/treeModel to 'linked'

See: http://www.saxonica.com/documentation9.6/index.html#!configuration/config-features

In Saxon/C a EE license is required to do XQuery update. See C++ code below to set the configuration property:

 SaxonProcessor * processor = new SaxonProcessor(true);
 processor->setConfigurationProperty("http://saxon.sf.net/feature/treeModel", "linked");

History

#1 Updated by O'Neil Delpratt over 1 year ago

  • Description updated (diff)
  • Status changed from New to In Progress

Added the setUpdating() method in the XQueryProcessor class.

Please register to edit this issue

Also available in: Atom PDF