Project

Profile

Help

Bug #3993

closed

Dynamic disabling of xsl:evaluate

Added by Michael Kay over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XSLT conformance
Sprint/Milestone:
-
Start date:
2018-11-03
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.8, 9.9
Fix Committed on Branch:
9.8, 9.9
Fixed in Maintenance Release:
Platforms:

Description

(1) Setting the configuration property Feature.DISABLE_XSL_EVALUATE does not work. It says the property is not recognised.

(2) The specification says that when xsl:evaluate is dynamically disabled, any xsl:fallback child instructions should be evaluated. We do not have the capability to do this, because xsl:fallback instructions are discarded at compile time.

(3) The result of system-property("xsl:supports-dynamic-evaluation") does not take into account whether or not xsl:evaluate has been disabled.

(4) Under Saxon-HE, xsl:evaluate is always statically disabled, so xsl:fallback should take effect, but this is not happening

(5) Under Saxon-PE/EE, if xsl:evaluate is statically disabled by setting a configuration property (or by running without a license), xsl:fallback should take effect, but this is not happening, even with JIT compilation of template rules disabled

Actions #1

Updated by Michael Kay over 3 years ago

Fixed the first problem in Configuration initializing code for booleanFeatures (9.9) or booleanPropertyNames (9.8).

The second problem is harder...

Actions #2

Updated by Michael Kay over 3 years ago

  • Description updated (diff)
Actions #3

Updated by Michael Kay over 3 years ago

  • Description updated (diff)
Actions #4

Updated by Michael Kay over 3 years ago

All now working on 9.9 branch; new unit tests s9apiTest/TestXslEvaluate. Need to regression test.

Actions #5

Updated by Michael Kay over 3 years ago

  • Status changed from New to Resolved
  • Applies to branch 9.8, 9.9 added
  • Fix Committed on Branch 9.8, 9.9 added

Patch committed for 9.8 and 9.9, with new unit tests.

For 9.8, I have not attempted to fix problem (2) (executing xsl:fallback when xsl:evaluate is dynamically evaluated) because the change is fairly disruptive.

Actions #6

Updated by O'Neil Delpratt over 3 years ago

  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 9.8.0.15 added

Bug fix applied in the Saxon 9.8.0.15 maintenance release. Leave open to the Saxon 9.9 maintenance release.

Actions #7

Updated by O'Neil Delpratt over 3 years ago

  • Status changed from Resolved to Closed
  • Fixed in Maintenance Release 9.9.0.2 added

Bug fix applied in the Saxon 9.9.0.2 maintenance release.

Please register to edit this issue

Also available in: Atom PDF