Project

Profile

Help

Bug #4447

Grouping with type declaration → XQST0094

Added by Christian Grün over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XQuery conformance
Sprint/Milestone:
-
Start date:
2020-01-29
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.9, trunk
Fix Committed on Branch:
9.9, trunk
Fixed in Maintenance Release:
Platforms:

Description

The following query doesn’t return x, but raises XQST0094:

for $i in 'x'
group by $g as xs:string := $i
return $g

History

#1 Updated by Michael Kay over 1 year ago

  • Category set to XQuery conformance
  • Status changed from New to In Progress
  • Assignee set to Michael Kay
  • Priority changed from Low to Normal

Despite XQuery 3.0 being published nearly 6 years ago, it seems that (a) there are no tests in QT3 that use the "as" clause to declare the type of the grouping variable, (b) Saxon does not implement the "as" clause, and (c) no-one until now has noticed.

#2 Updated by Michael Kay over 1 year ago

Created QT3 test cases group-by-021 to -024

#3 Updated by Michael Kay over 1 year ago

  • Status changed from In Progress to Resolved
  • Applies to branch trunk added
  • Fix Committed on Branch 9.9, trunk added

Fixed.

#4 Updated by O'Neil Delpratt over 1 year ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 9.9.1.7 added

Patch applied in the 9.9.1.7 maintenance release.

Please register to edit this issue

Also available in: Atom PDF