Project

Profile

Help

Bug #4602

closed

Failure to locate parameter document: wrong base URI

Added by Michael Kay about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Serialization
Sprint/Milestone:
-
Start date:
2020-06-17
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
10, 9.9
Fix Committed on Branch:
10, 9.9
Fixed in Maintenance Release:
Platforms:

Description

See test case output-0722

When a serialization parameter document is referenced from a result-document instruction in a stylesheet module held in a subdirectory, the wrong base URI is used for resolving the parameter document URI.

Actions #1

Updated by Michael Kay about 2 years ago

Both the xsl:output declaration and the xsl:result-document instruction place the static base URI in the (Saxon-internal) serialization property saxon:parameter-document-base-uri, and the xsl:result-document one wins. The problem is that a parameter document could be listed in either place (or indeed in both). I think the safest approach is that xsl:result-document should set this property only if there is a parameter-document attribute present on the instruction.

Actions #2

Updated by Michael Kay about 2 years ago

  • Status changed from New to Resolved
  • Applies to branch 9.9 added
  • Fix Committed on Branch 10, 9.9 added

Patch committed (to ResultDocument.java) on the 9.9 and 10 branches. The patch ensures that xsl:result-document only sets the parameter document base URI if the local properties include parameter-document.

(I'm not quite sure why the code is keeping parameter document base URI as a separate property, rather than resolving the URI as soon as it is encountered. But I prefer not to change the design right now. It might be related to the fact that the relative URI and base URI have to be supplied separately to the URIResolver.)

Actions #3

Updated by O'Neil Delpratt almost 2 years ago

  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 10.2 added

Bug fix applied in the Saxon 10.2 maintenance release.

Actions #4

Updated by O'Neil Delpratt over 1 year ago

  • Status changed from Resolved to Closed
  • Fixed in Maintenance Release 9.9.1.8 added

Bug fix applied on the Saxon 9.9.1.8 maintenance release.

Please register to edit this issue

Also available in: Atom PDF