Project

Profile

Help

Bug #4871

closed

Empty root element is not serialized correcly.

Added by Michael Kay over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Serialization
Sprint/Milestone:
-
Start date:
2021-01-02
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
10, trunk
Fix Committed on Branch:
10, trunk
Fixed in Maintenance Release:
Platforms:

Description

Same bug as in Saxon-JS (bug #4863).

Revealed by new test case output-0724.

Actions #1

Updated by Michael Kay over 1 year ago

  • Description updated (diff)
  • Category set to Serialization
  • Assignee changed from Michael Kay to Norm Tovey-Walsh
  • Priority changed from Low to Normal
Actions #2

Updated by Norm Tovey-Walsh over 1 year ago

  • Status changed from New to Resolved
  • Fix Committed on Branch 10, trunk added

Fixed with an analogous change to the one for #4863.

Actions #3

Updated by Michael Kay over 1 year ago

  • Status changed from Resolved to In Progress
  • Applies to branch 10, trunk added

Norm, in both 10 and 11, the new test case output-0724 seems to be failing. The expected result of the test is

<!DOCTYPE HTML><input value="✈" type="text"/>

but it's producing

<!DOCTYPE HTML><input value="✈" type="text">

(Note the "/" at the end.) Not sure without checking which is correct...

Actions #4

Updated by Norm Tovey-Walsh over 1 year ago

This is a bug in the test. I've submitted a PR to the test suite repo to fix it and confirmed the results by actually running the test suite driver :-)

Actions #5

Updated by Norm Tovey-Walsh over 1 year ago

  • Status changed from In Progress to Resolved
Actions #6

Updated by O'Neil Delpratt over 1 year ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 10.5 added

Bug fix applied to Saxon 10.5 maintenance release.

Please register to edit this issue

Also available in: Atom PDF