Project

Profile

Help

Support #5173

closed

Certain XQuery update operations seem to be failing with Saxon 10

Added by Radu Coravu 9 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
2021-11-24
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
10
Fix Committed on Branch:
10
Fixed in Maintenance Release:
Platforms:

Description

We have an auto test which takes these operations: https://dev.w3.org/2007/xquery-update-10-test-suite/

and runs them with Saxon.

The following scripts:


xqTestSuite\Queries\XQuery\InsertExpressions\id-insert-expr-086.xq
xqTestSuite\Queries\XQuery\ReplaceExpressions\id-replace-expr-045.xq
xqTestSuite\Queries\XQuery\ReplaceExpressions\id-replace-expr-045-no-inherit.xq
xqTestSuite\Queries\XQuery\RenameExpressions\id-rename-expr-033.xq
xqTestSuite\Queries\XQuery\RenameExpressions\id-rename-expr-034.xq
xqTestSuite\Queries\XQuery\RenameExpressions\id-rename-expr-033-no-inherit.xq
xqTestSuite\Queries\XQuery\RenameExpressions\id-rename-expr-034-no-inherit.xq

when run over an empty XML document used to produce in the output file with Saxon 9 the string:

http://www.example.com/hisco

but now produce an empty string.


Related issues

Is duplicate of Saxon - Bug #4974: XQuery Update: namespace propagation is not workingClosedMichael Kay2021-04-20

Actions

Please register to edit this issue

Also available in: Atom PDF