Project

Profile

Help

Omit blank line in text output

Added by Skip Addison almost 8 years ago

I'm using Saxon-CE to convert some values buried in the middle of an XML file to a tab-separated text file for import into a program that doesn't provide native XML support. It's working great. Thanks for creating this program, and thanks to the extended XQuery community.

I have one annoyance I'd like to get rid of. The output file includes a blank initial line. Here's the output:


id	action	eff_date	gender	active_status	deceased
 10183	add	20-Nov-2012	Male	Active	Yes
 RECORD COUNT: 1

Neither of the following prologs seem to work.

declare namespace saxon="http://saxon.sf.net/";
declare option saxon:output "method=text";
and
declare namespace saxon="http://saxon.sf.net/";
declare option saxon:output "omit-xml-declaration=yes";
Any suggestions?

Replies (2)

RE: Omit blank line in text output - Added by Michael Kay almost 8 years ago

I think you've raised this on the wrong forum: Saxon-CE is the client-side XSLT 2.0 implementation (with no XQuery and no serialization). I'll reclassify it as appropriate.

You should be using method=text here, and there should be no initial blank line. If your query is outputting an initial blank line, then I think we will need to see the query to understand why - and perhaps see the way you are invoking the query, in case that is relevant.

RE: Omit blank line in text output - Added by Skip Addison almost 8 years ago

Oops. You're right. I'm using Saxon-HE 9.4.0.6J. Sorry for the brain fart.

In any case, when I looked at the query again, I realized what the problem was. ... So, never mind. Thanks for being responsive.

    (1-2/2)

    Please register to reply