Project

Profile

Help

www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load

Added by Matt Wallis about 7 years ago

I'm using Firefox 23.0.1 on Mac OS/X 10.7.5.

Attempting to load www.saxonica.com/ce/user-doc/1.1/index.html‎ produces the Mac beach ball of doom, and Firefox becomes unresponsive. After waiting for several minutes, the only way out was to "Force Quit" Firefox.

Apart from that, I've had a brilliant day implementing a web app using Saxon CE - so much nicer than other popular approaches!

Regards, Matt Wallis


Replies (10)

Please register to reply

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by O'Neil Delpratt about 7 years ago

There seems to be a spurious character in the link you have added in comment #0.

The URL does work. http://www.saxonica.com/ce/user-doc/1.1/index.html

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Matt Wallis about 7 years ago

Any spurious characters come from my flawed cut&paste into the comment, not in my loading the link into the browser.

I get the same problem when I click on the link you provided in your comment: it gets as far as saying "loading documentation ...", but hangs. I Force Quit Firefox after waiting for 5 minutes.

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Matt Wallis about 7 years ago

Looking at the browser console output after clicking on the link you provided, there a bunch of CSS errors in cetree.css, but these shouldn't be a problem.

The last line of the console output indicates that is has successfully loaded http://www.saxonica.com/ce/user-doc/1.1/Saxonce/<HEX_CHARACTERS>.cache.js. (I can't paste the console output here because Firefox has hung, making it impossible to copy from there to the system clipboard.)

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Matt Wallis about 7 years ago

Using Safari, it works fine. Did you try it with Firefox?

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Michael Kay about 7 years ago

It's failing for me as well with Firefox 23.0.1 on Mac. Works fine with Firefox 20 on Windows.

Both the CE and the main documentation hang. Browser details:

Date/Time: 2013-08-28 09:03:20 +0100 OS Version: 10.7.5 (Build 11G63) Architecture: x86_64 Report Version: 9

Command: Firefox Path: /Applications/Firefox.app/Contents/MacOS/firefox Version: 23.0.1 (2313.8.14) Parent: launchd [155]

PID: 65056 Event: hang Duration: 2.86s Steps: 30 (100ms sampling interval)

Pageins: 2 Pageouts: 0

Process: firefox [65056] Path: /Applications/Firefox.app/Contents/MacOS/firefox Architecture: x86_64 UID: 501

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Michael Kay about 7 years ago

Upgraded (!) to Firefox 23.0.1 on Windows, and it hangs there too.

Sigh - this is why I abandoned Firefox, they feed you with a constant stream of updates that don't work.

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by Michael Kay about 7 years ago

The other Saxon-CE demos also seem to hang under Firefox 23.0.1.

RE: www.saxonica.com/ce/user-doc/1.1/index.html‎ fails to load - Added by O'Neil Delpratt about 7 years ago

I am experiencing the same hang issue on my android mobile which has Firefox 23.0 installed.

    (1-10/10)

    Please register to reply