Project

Profile

Help

open-source 3.0 support

Added by Vladimir Nesterovsky about 4 years ago

Hello!

On the saxonica welcome page it's written now: "Support for XQuery 3.0 and XPath 3.0 (now Recommendations) has been added to the open-source product."

Can you please confirm that is the case?

I attempted to use xsl:try and map() and it failed. Saxon 9.6 sources on svn do not contain implementation of try instruction, and that's how map() is implemented:

protected Expression parseMapExpression() throws XPathException { grumble("map expressions require XPath 3.0/XQuery 3.0 to be enabled"); return new ErrorExpression(); }


Replies (1)

RE: open-source 3.0 support - Added by Michael Kay about 4 years ago

xsl:try and the map{} expression are both defined in XSLT 3.0, not in XQuery 3.0 or XPath 3.0. Now that XPath 3.0 and XQuery 3.0 are W3C recommendations, we've moved support (at the minimum conformance level) into Saxon-HE, but XSLT 3.0 is still at Working Draft status so we're restricting support to the commercial editions for the time being.

I'm afraid the error messages in your code snippet is misleading (I think it's been carried over from the previous release without change). It should probably say "require Saxon-PE or -EE" (or better, produce a different message depending on the actual configuration).

    (1-1/1)

    Please register to reply