Project

Profile

Help

-s and -xp option doesn't seem to find the input file with HTTPS URI

Added by Martin Honnen over 1 year ago

Running Saxon-JS 2.1 and Node.js 14 under Windows 10, I am struggling to get the -s option to work with the -xp option and a HTTPS URI like https://martin-honnen.github.io/xslt/2021/sample3.xml, I get an error

Saxon-JS 2.1 from Saxonica
Node.js version v14.16.0
ENOENT: no such file or directory, stat 'https://martin-honnen.github.io/xslt/2021/sample3.xml'

The documentation suggests a URI should work:

The value may either be a filename (taken as relative to the current working directory), or a URI starting with file:/, http:/, or https:/


Replies (1)

-s and -xp option doesn't seem to find the input file with HTTPS URI - Added by Norm Tovey-Walsh over 1 year ago

Running Saxon-JS 2.1 and Node.js 14 under Windows 10, I am struggling
to get the -s option to work with the -xp option and a HTTPS URI
like https://martin-honnen.github.io/xslt/2021/sample3.xml, I get an
error

Saxon-JS 2.1 from Saxonica  
Node.js version v14.16.0  
ENOENT: no such file or directory, stat 'https://martin-honnen.github.io/xslt/2021/sample3.xml'  

Unfortunately, the -xp option in Saxon-JS 2.1 doesn’t understand http(s)
URIs. It assumes that the -s option is a file. It was an oversight in
getting an experimental feature into the release. It’s been resolved for
the next release. Sorry about that.

Be seeing you,
norm

--
Norm Tovey-Walsh
Saxonica

    (1-1/1)

    Please register to reply