Project

Profile

Help

Bug #1556

closed

adding ?logLevel=FINE throws error

Added by Jim Fuller over 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
2012-06-18
Due date:
% Done:

100%

Estimated time:
Platforms:

Description

I have a trial license and testing via localhost ... when I want to get back error info, it is my understanding adding ?logLevel=FINE to Saxonce.nocache.js would start writing error to console.log.

to my surprise adding this threw a license error ... is it intended behavior ?

Actions #1

Updated by Philip Fearon over 10 years ago

If I understand correctly: you didn't get a license error initially, but then got one after adding the logLevel attribtue value 'FINE' to the URL - the most likely explanation is that you were using a previous version of Saxon-CE requiring another license-file, the URL change then caused the browser to refresh the cache, switching from a cached old version of Saxon-CE (beta 0.2?) to the newer version of Saxon-CE (1.0?) - thus requiring a newer license file with a different name.

A test for this is if you revert to the previous URL without the logLevel attribute you should still see the license error message:

No Saxon-CE license found at: http://localhost/{your path}/saxonce-license-1.txt

Is this the case?

If so, this situation reflects that there are some difficulties with the browser cache - especially when updating the processor, the best approach in these cases is to explicitly clear the entire cache using whatever method your own browser provides. You will then kinow in a more timely manner that the license file is not in the expected location.

Actions #2

Updated by Jim Fuller over 10 years ago

Philip Fearon wrote:

If I understand correctly: you didn't get a license error initially, but then got one after adding the logLevel attribtue value 'FINE' to the URL - the most likely explanation is that you were using a previous version of Saxon-CE requiring another license-file, the URL change then caused the browser to refresh the cache, switching from a cached old version of Saxon-CE (beta 0.2?) to the newer version of Saxon-CE (1.0?) - thus requiring a newer license file with a different name.

i've already tried to isolate this issue;

  • firebug cache disable is on

  • no old saxon ce in effect

  • works without appending ?logLevel=FINE

I also tried with a different browser with zero cache and still get issue;

the specific error I get is;

SaxonCE.XSLT20Processor 12:07:52.860

SEVERE: LicenseException in onModuleLoad: No Saxon-CE license found at: http://saxonce-license-1.txt

http://localhost/saxon-ce-1.0/SaxonceDebug/C13D740AA47BA044EDA03E6F9AA2CB78.cache.html

Line 4049

I think something else is in play here

Actions #3

Updated by Jim Fuller over 10 years ago

note I get the same behaviour if I just append a ? to the end of script url

<script type="text/javascript" language="javascript" src="saxon/Saxonce/Saxonce.nocache.js?"></script>
Actions #4

Updated by Jim Fuller over 10 years ago

and

<script type="text/javascript" language="javascript" src="saxon/SaxonceDebug/Saxonce.nocache.js?"></script>
Actions #5

Updated by Jim Fuller over 10 years ago

ok me stupid ....

for some reason I thought this was to be appended to the script invoke, versus the actual url

I think this is probably not a bug ;)

Actions #6

Updated by Philip Fearon over 10 years ago

Ok thanks, I expect there's an ambiguity in the documentation (like explicitly stating it's the URL of the host page that is being referred to and ensuring an example is always used to underline this) that led to this assumption so I'll look to correct this.

Actions #7

Updated by Philip Fearon over 10 years ago

  • Status changed from New to Resolved
Actions #8

Updated by O'Neil Delpratt almost 10 years ago

  • Status changed from Resolved to Closed
  • Sprint/Milestone set to Release 1.1
  • % Done changed from 0 to 100
  • Found in version set to 1.0
  • Fixed in version set to 1.1

Bug fixed for Saxon-CE version 1.1 release

Please register to edit this issue

Also available in: Atom PDF