Project

Profile

Help

Bug #1563

closed

Unhelpful error message when using the '/' root node expression with no context item

Added by Philip Fearon over 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Sprint/Milestone:
Start date:
2012-06-20
Due date:
% Done:

100%

Estimated time:
Platforms:

Description

Using an XPath expression such as in the instruction <xsl:value-of select="/any"/> when there is no context item results in an error message such as 'unable to get the value of property Qe: object is null...'

The error message should be similar to: Error XPDY0002: at /xsl:transform/xsl:function/xsl:value-of: Leading '/' cannot select the root

node of the tree containing the context item: the context item is undefined

This is now resolved - the cause was associated with the building of the error message

Actions #1

Updated by O'Neil Delpratt almost 10 years ago

  • Status changed from Resolved to Closed
  • Sprint/Milestone set to Release 1.1
  • Fixed in version set to 1.1

Bug fixed for Saxon-CE version 1.1 release

Please register to edit this issue

Also available in: Atom PDF