Project

Profile

Help

Bug #1669

Firefox not starting transformation

Added by Manfred Staudinger over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Low
Sprint/Milestone:
-
Start date:
2012-12-27
Due date:
% Done:

0%

Estimated time:

Description

Initiating the XSLT 2.0 transform with an XSLT 1.0 stylesheet by inserting

<script type="text/javascript" language="javascript" src="../../SaxonceDebug/Saxonce.nocache.js"/>
<script type="text/javascript" language="javascript">
	onSaxonLoad = function() {
		proc = Saxon.run({
			initialTemplate: 'main',
			logLevel: 'FINE',
			stylesheet: '../view_all_0.xsl'
		});
	}
</script>
<xsl:template name="main">
	<xsl:result-document href="#htmlbody" method="ixsl:replace-content">
		<xsl:apply-templates select="ixsl:page()/*/*/*[@id='htmlbody']/*" mode="init"/>
	</xsl:result-document>
</xsl:template>
FINE: Commencing transform type:UPDATE_HTML
FINE: processing result-document for href: htmlbody
FINE: Transform complete
INFO: Saxon-CE API initialised
<script defer="defer">Saxonce.onInjectionDone('Saxonce')</script>
view_all_0.xsl (1.37 KB) view_all_0.xsl Manfred Staudinger, 2013-02-18 12:04
view_names_0.xsl (2.14 KB) view_names_0.xsl Manfred Staudinger, 2013-02-18 12:05
Questenberg_Herman_von_0.xml (930 Bytes) Questenberg_Herman_von_0.xml Manfred Staudinger, 2013-02-18 12:06

History

#1 Updated by Michael Kay over 7 years ago

Thanks for reporting it. If it's OK, I'll take you at your word that this is low priority and we'll deal with it when we're back after the holidays.

#2 Updated by O'Neil Delpratt over 7 years ago

  • Status changed from New to In Progress
  • Assignee set to O'Neil Delpratt

Hi Manfred,

Sorry for the delay in looking into this bug. I am looking at it now. Please may you send me the HTMl and stylesheet you use to reproduce the error. You can attach it to this bug report or send it privately if the data is sensitive.

#3 Updated by Manfred Staudinger over 7 years ago

No problem with the delay. I'm now at Firefox 18.0.1 but the problem is the same. The test shows a "Version:" in the lower left corner for Firefox, but a "Version2:" for Opera and Chrome.

#4 Updated by O'Neil Delpratt over 7 years ago

Hi Manfred, would you be able to send the html file as well.

thanks

#5 Updated by O'Neil Delpratt over 7 years ago

Please ignore my request. I see the view_name_0.xsl is used to generate the html file.

#6 Updated by O'Neil Delpratt over 7 years ago

Hi Manfred,

I managed to run your app with Saxon-ce 1.0, but did not reproduce the issue you reported.

I have tried it on Firefox version 13.0.1 and 18.0.2 and it works fine.

On my firefox console it produces the messages:

FINE: Commencing transform type:UPDATE_HTML
FINE: processing result-document for href: htmlbody
INFO: template match=html:div[@id=htmlbody]/html:h3 mode=init
FINE: Transform complete
INFO: Saxon-CE API initialised

This is the same on all browsers

Is your environment different in anyway? Please check the version of Saxon-CE you are running.

#7 Updated by Michael Kay almost 7 years ago

  • Status changed from In Progress to Closed

I am closing this without resolution, as it seems that without further information we are unlikely to discover what went wrong.

Please register to edit this issue

Also available in: Atom PDF