Project

Profile

Help

Bug #3036

Saxon-JS documentation app problems in Chrome on computers with touch screens

Added by Debbie Lockett over 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Sprint/Milestone:
-
Start date:
2016-11-18
Due date:
% Done:

100%

Applies to JS Branch:
0.9, 1.0
Fix Committed on JS Branch:
1.0
Fixed in JS Release:
SEF Generated with:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

As reported by a user, the Saxon-JS documentation app at http://www.saxonica.com/saxon-js/documentation/ does not work in the Windows 32-bit version of Chrome.

It seems to load (to the initial 'About Saxon-JS' page), but then is unusable. Clicking on the page navigation links does nothing.

There is no issue with the 64-bit version of Chrome (on Windows, and Mac).

History

#1 Updated by Debbie Lockett over 1 year ago

  • Subject changed from Saxon-JS documentation app not working with the Windows 32-bit version of Chrome to Saxon-JS documentation app problems in Chrome on computers with touch screens
  • Status changed from New to In Progress

Further investigations have revealed that the problem occurs on computers which have touch screens. In the Chrome browser, the documentation app navigation does not work with mouse clicks, but does work with touch events. So the problem is in the design of the event handling in the documentation app.

The documentation app affectively assumes that if touch events are possible, then mouse clicks are not. Clearly this needs updating since there are devices that allow both.

#2 Updated by Debbie Lockett over 1 year ago

  • Assignee set to Debbie Lockett

#3 Updated by Debbie Lockett about 1 year ago

  • Status changed from In Progress to Resolved

I have updated the design of the documentation app, to remove the difference for touch and click events, so it should now be working without problems for devices which allow both.

The previous app design assumed that devices only used one or the other type of event, with separate (but very similar) event handling templates for the different cases (with mode="ixsl:onclick" and mode="ixsl:ontouchend"). The "onclick" templates were then disabled for a device which allowed touches.

In the redesign, we no longer need separate templates specifically for touch events. It is now standard for touch events to trigger click events (if they are not cancelled during an interaction, e.g. by moving the touch), so the click event handling templates are sufficient. (Perhaps this was not the case previously, when the Saxon-CE documentation app was originally designed; which was used as the basis for the Saxon-JS documentation.)

This has also improved the usability of the documentation app on touch devices in general - previously, scrolling the navigation menu would also trigger a page navigation (from the 'touch point'), but now this doesn't happen.

#4 Updated by Debbie Lockett 10 months ago

  • Applies to JS Branch 0.9, 1.0 added
  • Fix Committed on JS Branch 1.0 added

#5 Updated by Debbie Lockett 10 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 1.0.1

Bug fix applied in Saxon-JS 1.0.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF Tracking page