Project

Profile

Help

Bug #3381

Spurious "unmatched ')'" error in regular expression

Added by Michael Kay 11 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
2017-08-10
Due date:
% Done:

100%

Applies to JS Branch:
0.9, 1.0, Trunk
Fix Committed on JS Branch:
1.0, Trunk
Fixed in JS Release:
SEF Generated with:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

Saxon-JS reports "unmatched ')'" in a regular expression, caused by failing to ignore ')' characters that appear within a character class (that is, within square brackets).

Shows up in test case analyze-string-097.

When we fix this the test shows a further error, caused by incorrect treatment of escaped hyphens within square brackets: the backslash is being incorrectly removed.

History

#1 Updated by Michael Kay 11 months ago

  • Priority changed from Low to Normal
  • Applies to JS Branch 0.9, 1.0, Trunk added
  • Fix Committed on JS Branch Trunk added

The same test also showed up one further errors: "\$" outside square brackets was (for some unfathomable reason) being replaced by "$".

Changes made on the 2.0 branch and the test case is now working.

#2 Updated by Debbie Lockett 4 months ago

  • Status changed from New to Resolved
  • Fix Committed on JS Branch 1.0 added

Relevant fixes in regex.js (belatedly) also made on 1.0 branch.

#3 Updated by Debbie Lockett 2 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 1.1.0

Bug fix applied in the Saxon-JS 1.1.0 maintenance release.

Please register to edit this issue

Also available in: Atom PDF Tracking page