Project

Profile

Help

Bug #4200

xmlns="" is generated if use Saxon 9.8.0.15 with DITA-OT 3.3.1

Added by Toshihiko Makita 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Third-party product
Sprint/Milestone:
-
Start date:
2019-04-18
Due date:
% Done:

0%

Legacy ID:
Applies to branch:
9.8, 9.9
Fix Committed on Branch:
Fixed in Maintenance Release:

Description

I'm not sure whether this cause is Saxon or not. But DITA-OT developers has no reply about this issue on GitHub.

[Steps to reproduce]

  1. Download DITA-OT 3.3.1 from https://www.dita-ot.org/download . This version bundles Saxon-HE 9.8.0.14 as its XSLT processor (dita-ot-3.3.1/lib).
  2. Open command window at dita-ot-3.3.1.
  3. Enter "bin/dita --install".

This command makes normal catalog file:

D:\DITA-OT\dita-ot-3.3.1\plugins\org.dita.base\catalog-dita.xml

<?xml version="1.0" encoding="UTF-8"?><!--
This file is part of the DITA Open Toolkit project.
Copyright 2004, 2005 IBM Corporation
See the accompanying LICENSE file for applicable license.
--><catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog" xmlns:dita="http://dita-ot.sourceforge.net">
  <rewriteURI uriStartString="platform:" rewritePrefix="../../"/>
  <rewriteURI uriStartString="plugin:org.dita.htmlhelp:" rewritePrefix="../org.dita.htmlhelp/"/><rewriteURI uriStartString="plugin:org.dita.base:" rewritePrefix="../org.dita.base/"/><rewriteURI uriStartString="plugin:org.dita.pdf2.xep:" rewritePrefix="../org.dita.pdf2.xep/"/><rewriteURI uriStartString="plugin:com.sophos.tocjs:" rewritePrefix="../com.sophos.tocjs/"/><rewriteURI uriStartString="plugin:org.dita.pdf2.fop:" rewritePrefix="../org.dita.pdf2.fop/"/><rewriteURI uriStartString="plugin:org.dita.eclipsehelp:" rewritePrefix="../org.dita.eclipsehelp/"/><rewriteURI uriStartString="plugin:org.dita.specialization.dita11:" rewritePrefix="../org.dita.specialization.dita11/"/><rewriteURI uriStartString="plugin:org.dita.normalize:" rewritePrefix="../org.dita.normalize/"/><rewriteURI uriStartString="plugin:org.oasis-open.xdita.v0_2_2:" rewritePrefix="../org.oasis-open.xdita.v0_2_2/"/><rewriteURI uriStartString="plugin:org.dita.troff:" rewritePrefix="../org.dita.troff/"/><rewriteURI uriStartString="plugin:org.dita.pdf2.axf:" rewritePrefix="../org.dita.pdf2.axf/"/><rewriteURI uriStartString="plugin:org.dita.html5:" rewritePrefix="../org.dita.html5/"/><rewriteURI uriStartString="plugin:org.lwdita:" rewritePrefix="../org.lwdita/"/><rewriteURI uriStartString="plugin:org.dita.xhtml:" rewritePrefix="../org.dita.xhtml/"/><rewriteURI uriStartString="plugin:org.dita.pdf2:" rewritePrefix="../org.dita.pdf2/"/><rewriteURI uriStartString="plugin:org.oasis-open.dita.v1_2:" rewritePrefix="../org.oasis-open.dita.v1_2/"/><rewriteURI uriStartString="plugin:org.oasis-open.dita.v1_3:" rewritePrefix="../org.oasis-open.dita.v1_3/"/>
   <nextCatalog catalog="../org.oasis-open.dita.v1_3/catalog.xml"/><nextCatalog catalog="../org.oasis-open.dita.v1_2/catalog.xml"/><nextCatalog catalog="../org.dita.pdf2/cfg/catalog.xml"/><nextCatalog catalog="../org.dita.specialization.dita11/catalog.xml"/><nextCatalog catalog="../org.oasis-open.xdita.v0_2_2/catalog-dita.xml"/>
</catalog>
  1. Remove dita-ot-3.3.1\lib\Saxon-HE-9.8.0-14.jar and copy Saxon-HE(or PE) 9.8.0.15's .jar into lib folder.
  2. Enter "bin/dita --install" command again.
  3. The catalog file is generated but with redundant xmlns="" . As a result, all of the DITA-OT build attempts fails because catalog file is invalid.
<?xml version="1.0" encoding="UTF-8"?><!--
This file is part of the DITA Open Toolkit project.
Copyright 2004, 2005 IBM Corporation
See the accompanying LICENSE file for applicable license.
--><catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog" xmlns:dita="http://dita-ot.sourceforge.net">
  <rewriteURI uriStartString="platform:" rewritePrefix="../../"/>
  <rewriteURI xmlns="" uriStartString="plugin:org.dita.htmlhelp:" rewritePrefix="../org.dita.htmlhelp/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.base:" rewritePrefix="../org.dita.base/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.pdf2.xep:" rewritePrefix="../org.dita.pdf2.xep/"/><rewriteURI xmlns="" uriStartString="plugin:com.sophos.tocjs:" rewritePrefix="../com.sophos.tocjs/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.pdf2.fop:" rewritePrefix="../org.dita.pdf2.fop/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.eclipsehelp:" rewritePrefix="../org.dita.eclipsehelp/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.specialization.dita11:" rewritePrefix="../org.dita.specialization.dita11/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.normalize:" rewritePrefix="../org.dita.normalize/"/><rewriteURI xmlns="" uriStartString="plugin:org.oasis-open.xdita.v0_2_2:" rewritePrefix="../org.oasis-open.xdita.v0_2_2/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.troff:" rewritePrefix="../org.dita.troff/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.pdf2.axf:" rewritePrefix="../org.dita.pdf2.axf/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.html5:" rewritePrefix="../org.dita.html5/"/><rewriteURI xmlns="" uriStartString="plugin:org.lwdita:" rewritePrefix="../org.lwdita/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.xhtml:" rewritePrefix="../org.dita.xhtml/"/><rewriteURI xmlns="" uriStartString="plugin:org.dita.pdf2:" rewritePrefix="../org.dita.pdf2/"/><rewriteURI xmlns="" uriStartString="plugin:org.oasis-open.dita.v1_2:" rewritePrefix="../org.oasis-open.dita.v1_2/"/><rewriteURI xmlns="" uriStartString="plugin:org.oasis-open.dita.v1_3:" rewritePrefix="../org.oasis-open.dita.v1_3/"/>
   <nextCatalog catalog="../org.oasis-open.dita.v1_3/catalog.xml"/><nextCatalog catalog="../org.oasis-open.dita.v1_2/catalog.xml"/><nextCatalog catalog="../org.dita.pdf2/cfg/catalog.xml"/><nextCatalog catalog="../org.dita.specialization.dita11/catalog.xml"/><nextCatalog catalog="../org.oasis-open.xdita.v0_2_2/catalog-dita.xml"/>
</catalog>

I have users who needs Saxon-PE with the newest DITA-OT. However, both Saxon-PE 9.9.1 and Saxon-PE 9.8.15 does not work with DITA-OT 3.3.1. This is very confusing.

[Reference DITA-OT ticket]

OT 3.3.1 with Saxon-PE 9.9.1 fails in mapref https://github.com/dita-ot/dita-ot/issues/3279

OT 3.3.1 With Saxon-HE 9.8.0.15 Generates Invalid Catalog File https://github.com/dita-ot/dita-ot/issues/3284

2019-04-18-2.png (9.71 KB) Toshihiko Makita, 2019-04-18 16:52 2019-04-18-2.png

History

#1 Updated by Michael Kay 5 months ago

I have reproduced the problem, but it's difficult to debug since it involves understanding a lot of DITA shell script and ant code, neither of which are languages that are easy to debug.

Looking at what changed between 9.8.0.14 and 9.8.0.15, a strong possibility is that we fixed bug #3889, and DITA was dependent on the incorrect behaviour of Saxon before that bug was fixed.

If that theory is correct, then it will need someone who knows DITA a lot better than I do to identify what DITA change is needed to make this work.

#2 Updated by Toshihiko Makita 5 months ago

Please close this ticket.

The cause is DITA-OT code bug. Not Saxon.

Regards,

-- /-------------------------------------------------- Toshihiko Makita Development Group. Antenna House, Inc. Ina Branch E-Mail tmakita@antenna.co.jp 8077-1 Horikita Minamiminowa Vil. Kamiina Co. Nagano Pref. 399-4511 Japan Tel +81-265-76-9300 Fax +81-265-78-1668 Web site: http://www.antenna.co.jp/ http://www.antennahouse.com/ --------------------------------------------------/

#3 Updated by Michael Kay 5 months ago

  • Category set to Third-party product
  • Status changed from New to Closed
  • Assignee set to Michael Kay
  • Priority changed from Low to Normal
  • Applies to branch 9.9 added

Please register to edit this issue

Also available in: Atom PDF