Project

Profile

Help

Feature #4492

closed

Saxon-JS cannot find '/lib/xpath/XPathJS.min.js' dependency running on some web browsers

Added by Gary Cornelius almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
2020-03-21
Due date:
% Done:

0%

Estimated time:
Applies to JS Branch:
1.0
Fix Committed on JS Branch:
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

I cannot run saxon-js on the Samsung Web browser on the TVs and smartwatches and think this should work as the browser there is based on the chromium browser...

The root cause appears to be that Saxon-JS cannot find the path for the XPathJS.min.js dependency requested by Saxon-JS. If possible can you please combine the XPathJS.min.js file into the same file as the Saxon-JS code as I think this is likely to resolve the issue and also would be more robust for all browsers.


Related issues

Is duplicate of SaxonJS - Bug #4103: Saxon-JS dynamic loading errors > it won't run on Tizen OS in a webapp browser (on Smartwatches and TVs)Closed2019-01-19

Actions
Actions #1

Updated by Debbie Lockett almost 4 years ago

  • Is duplicate of Bug #4103: Saxon-JS dynamic loading errors > it won't run on Tizen OS in a webapp browser (on Smartwatches and TVs) added
Actions #2

Updated by Debbie Lockett almost 4 years ago

  • Status changed from New to Duplicate

Hi Gary, this actually looks to be the same issue which you raised some time ago (#4103). But fair enough that because we have failed to respond, or provide updates there that you raised it again!

Saxon-JS 2.0 will indeed do away with the dynamic loading of the XPath module (lib/xpath/XPathJS.min.js for Saxon-JS 1.x), and the other internal Saxon-JS resources (contents of 'opt' directory). So it should work on other browsers (TV and smartwatches), not that we have tested those yet... (but let's move the discussion/ updates to the original bug).

Please register to edit this issue

Also available in: Atom PDF Tracking page