Project

Profile

Help

Bug #4780

closed

UntypedAtomic to xs:double conversion does not happen for a dynamic call to fn:abs#1

Added by Michael Kay over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XPath Conformance
Sprint/Milestone:
-
Start date:
2020-10-04
Due date:
% Done:

100%

Estimated time:
Applies to JS Branch:
2
Fix Committed on JS Branch:
2
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

XSLT3 Test case higher-order-functions-038 fails. The test makes a dynamic call on fn:abs#1 supplying an xs:untypedAtomic value that should be converted to a double. It appears that no conversion is attempted. The call fails:

Supplied value atomic:AZ('123.456') does not match required type xs:numeric? in dynamic call of Q{http://www.w3.org/2005/xpath-functions}abs#1

(Incidentally, should fix "atomic:AZ" in the error message)

Actions #1

Updated by Michael Kay over 3 years ago

Function coerce() at Expr.js#3034 is not handling a required type of xs:numeric correctly.

This is probably a consequence of the recent changes to refactor handling of atomic types.

Actions #2

Updated by Michael Kay over 3 years ago

Fixed coerce() function, test now working.

Actions #3

Updated by Michael Kay over 3 years ago

  • Status changed from New to Resolved
  • Applies to JS Branch 2.0, Trunk added
  • Fix Committed on JS Branch 2.0, Trunk added

Test case xs-numeric-019 was still failing in coerce() - not sure if this was a regression caused by this patch - but it's now fixed.

Actions #4

Updated by Community Admin over 3 years ago

  • Applies to JS Branch 2 added
  • Applies to JS Branch deleted (2.0, Trunk)
Actions #5

Updated by Community Admin over 3 years ago

  • Fix Committed on JS Branch 2 added
  • Fix Committed on JS Branch deleted (2.0, Trunk)
Actions #6

Updated by Debbie Lockett about 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 2.1

Bug fix applied in the Saxon-JS 2.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF Tracking page