Project

Profile

Help

Bug #5019

Invalid local name: 'xml:lang'

Added by T Hata 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Low
Category:
-
Sprint/Milestone:
-
Start date:
2021-06-08
Due date:
% Done:

100%

Estimated time:
Applies to JS Branch:
2
Fix Committed on JS Branch:
2
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

Loading test.html in Microsoft Edge 90 resulted in FORG0001.

Transformation failure: Error FORG0001 at stylesheet.xsl#7
    Invalid local name: 'xml:lang' (prefix='', uri='null')

stylesheet.sef.json was exported with this command.

java -cp saxon-ee-10.5.jar net.sf.saxon.Transform -t -xsl:stylesheet.xsl -export:stylesheet.sef.json -target:JS -nogo -relocate:on -ns:##html5

SaxonJS2.rt.js version is 2.2.

test.zip (812 Bytes) test.zip T Hata, 2021-06-08 10:54

History

#1 Updated by Debbie Lockett 6 months ago

  • Status changed from New to In Progress
  • Applies to JS Branch 2 added

Thanks for reporting the issue, and supplying the repro. I have reproduced the issue (on the Chrome browser), and added browser test iss5019.

#2 Updated by Debbie Lockett 6 months ago

The error gets thrown while processing the apply templates call in push mode. The focus is the window.document (as returned from ixsl:page()), but while traversing this tree, we attempt to process the html element's attributes (see Axis.attribute in DomUtils.js) but hit a problem with this xml:lang attribute. This attribute node has properties: attr.prefix = null, attr.prefix = null, attr.localName = "xml.lang", so we then get an error calling Atomic.XS.QName.fromParts, because the local name is invalid.

#3 Updated by Debbie Lockett 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee set to Debbie Lockett
  • Fix Committed on JS Branch 2 added

Fix committed in domutils.js to handle xml: namespace attributes in HTML documents.

#4 Updated by Debbie Lockett 3 months ago

  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 2.3

Bug fix applied in the Saxon-JS 2.3 maintenance release.

#5 Updated by Debbie Lockett 3 months ago

  • Status changed from Resolved to Closed

Please register to edit this issue

Also available in: Atom PDF Tracking page