Project

Profile

Help

Bug #5078

C#.Net: This "Evaluate()" statement take more time and memory consumption in 9.9.1.8 version.

Added by Dipak Shinde about 1 month ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
.NET API
Sprint/Milestone:
Start date:
2021-09-03
Due date:
% Done:

0%

Estimated time:
Legacy ID:
Applies to branch:
9.9
Fix Committed on Branch:
Fixed in Maintenance Release:
Platforms:

Description

    1. A per our business logic we have created rule(Xquery) and we are evaluating this with the help of evaluate method. 2 XQuery:

let $gReturnDataState := element{'ReturnDataState'} {''} let $gSchA...................

for $ReturnDataState at $currentReturnDataStatePos in if(....................

let $genSchA := false() let $genAllRealTangibleProperty...........

x:AllPropEndYrTotal x:ReturnState/x:ReturnDataState/x:SchA/x:AllRealTangibleProperty/x:AllPropEndYrTotal {$AllPropEndYrTotalData} ....................................

Code: XdmValue evaluations = evaluator.Evaluate();

  1. For few rules XQuery execution takes greater than 30GB memory.
Saxon API Query.txt (995 Bytes) Saxon API Query.txt Dipak Shinde, 2021-09-03 11:50

Related issues

Is duplicate of Saxon - Bug #5077: C#.Net: This "Evaluate()" statement take more time and memory consumption in 9.9.1.8 version.New2021-09-032021-09-03

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Dipak Shinde about 1 month ago

Please find the attachment for XQuery.

#2 Updated by Michael Kay about 1 month ago

We can't investigate a problem unless we can reproduce it. A query with lots of ellipses (....) is no use for diagnostics. With performance problems, the devil is always in the detail, so we need all the detail.

Your question says "9.9.1.8 takes more time and memory" but you haven't said what you are comparing with or how you are measuring it.

The biggest factor affecting memory use is usually the size of the source document being queried. How big is the source document?

#3 Updated by Dipak Shinde about 1 month ago

The source document is only 4.28GB.

#4 Updated by Dipak Shinde about 1 month ago

Sorry, The source document is only 4.28MB.

#5 Updated by Michael Kay about 1 month ago

Please try to package up your query and source document in a form that we can run it.

#6 Updated by Michael Kay about 1 month ago

  • Is duplicate of Bug #5077: C#.Net: This "Evaluate()" statement take more time and memory consumption in 9.9.1.8 version. added

#7 Updated by Michael Kay about 1 month ago

  • Status changed from New to Duplicate

Please register to edit this issue

Also available in: Atom PDF