Project

Profile

Help

Support #5146

closed

Code generation with Saxon-JS in Oxygen XML

Added by Oliver Budke 8 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
2021-10-26
Due date:
% Done:

0%

Estimated time:
Applies to JS Branch:
2
Fix Committed on JS Branch:
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

I tried to generate the code for the sample application "City List" with Saxon-JS inside Oxygen XML (add-on). https://www.saxonica.com/saxon-js/documentation/index.html#!samples/cities

However, the application is not responsive once it is run on a local webserver. When I use the provided cities.sef.json the application works fine. That's why I narrowed the problem down to this file.

I found a big diff between the two cities.sef.json files. Can someone explain where this diff comes from?

Environment:

Oxygen XML 23.1 Saxon 10.3 (no config file, -relocatable) Google Chrome / Mozilla Firefox (latest version) Saxon-JS 2.2 / 2.3 "Web Server for Chrome"


Files

cities.sef.json (12.8 KB) cities.sef.json Oliver Budke, 2021-10-26 15:22
clipboard-202110261604-98tot.png (18.4 KB) clipboard-202110261604-98tot.png Screenshot of the add-on Oliver Budke, 2021-10-26 16:04
Actions #1

Updated by Oliver Budke 8 months ago

The generated SEF is attached.

Actions #2

Updated by Debbie Lockett 8 months ago

A non-responsive application in the browser usually means that the SEF has been produced without the necessary namespace option; from the command line this is: -ns:##html5.

Is it possible to set this in the Oxygen XML add-on you're using? (I've got an older version of Oxygen, and I can't see it there unfortunately.)

Actions #3

Updated by Oliver Budke 8 months ago

Hello Debbie,

thanks for the quick reply. I could not set this option in Oxygen XML. My Oxygen add-on interface is attached. How can I set this in a configuration file?

Actions #4

Updated by Debbie Lockett 8 months ago

Oh dear, indeed it looks like this is an oversight for the Oxygen XML add-on; so should be raised as a bug directly with them.

I'm afraid I don't think it is possible to set the options for generating a Saxon-JS SEF using a configuration file. Sorry.

Actions #5

Updated by Michael Kay 8 months ago

I've invited Octavian (of Oxygen support) to comment here.

Actions #6

Updated by Octavian Nadolu 8 months ago

We investigated this issue and it seems that the problem is the -ns option, as Debbie said. You cannot set this option from the Oxygen XML Saxon add-on. From what I looked in the code this option must be set in the "XsltCompiler", and cannot be passed through the file configuration.

We added an issue on our side to add the option in the add-on interface, and then set it in the "XsltCompiler". When the issue will be solved we will release a new version of the add-on.

Actions #7

Updated by Michael Kay 8 months ago

Let me add one other point. The differences between the two SEF files are, I assume, because they were generated by two different compilers. The XJ compiler (written in Java, part of Saxon-EE) does much more static type checking and optimization than the XX compiler (written in XSLT, part of Saxon-JS), so the SEF files they produce will be quite different.

Actions #8

Updated by Debbie Lockett 8 months ago

In this instance, the SEFs are in fact both generated by Saxon-EE. The differences all come down to the use of the -ns option.

Actions #9

Updated by Michael Kay 4 months ago

  • Tracker changed from Bug to Support
  • Status changed from New to Closed
  • Assignee set to Michael Kay
  • Priority changed from High to Normal

Closing this as I think we determined that it was primarily an Oxygen problem.

Please register to edit this issue

Also available in: Atom PDF Tracking page