Project

Profile

Help

Backward compatibility in Saxon HE 10.X from HE 9.X?

Added by Javed Akhter 7 months ago

Hello,

Are there any breaking changes or reported backward compatibility issues in HE 10.X? Is it safe to just upgrade from HE 9.8 version to HE 10.2 version (.NET framework)?

Thank you, Javed.


Replies (2)

Backward compatibility in Saxon HE 10.X from HE 9.X? - Added by Michael Kay 7 months ago

There's a detailed list of changes from 9.8 to 10 at https://saxonica.com/documentation/index.html#!changes/all/9.8-10

It's a long list, I'm afraid, and it includes many items that could break your application. To take just one example that's highlighted in the documentation:

Whether in XSLT, XPath, or XQuery, previous releases of Saxon allowed sorting operations to mix untypedAtomic sort keys with keys of a more specific type, converting the untypedAtomic values to the other type if required. This has never been permitted by any of the specifications, and Saxon has now been changed to report a type error for such cases. This change is required for conformance with the W3C specifications, but it may cause existing applications to break.

There are many other similar points of detail.

So I would always recommend doing some regression testing of your application to make sure that it still works under the new release.

Michael Kay
Saxonica

On 29 Sep 2020, at 18:37, Saxonica Developer Community wrote:

RE: Backward compatibility in Saxon HE 10.X from HE 9.X? - Added by Javed Akhter 7 months ago

Thank you, Michael for the quick response. This helps.

    (1-2/2)

    Please register to reply