Project

Profile

Help

Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***)

Added by Deepak Pai 3 months ago

Our Javascript project uses the xslt3 for doing the transformation during the build process. We execute the following commad: 'xslt3 "-s:src/xsd/main.xsd" "-xsl:src/xsd/xsd2js.xsl" "-o:src/js/generated.js"';

It is installed as dev dependency. The package.json contains the line "xslt3": "^2.3.0" We are using node 14.16.1

The transformation was working just fine all this time until today. Initially the following error was throw:

Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***) Node.js version v14.16.1

Once I deleted the node_modules folder to rebuild all packages I get the following error (as it installs latest xslt3 2.4):

E:\prod\node_modules\xslt3\xslt3.js:44 var platform$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command=SaxonJS$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command.getPlatform(),thisProgram$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command=filepathToUri$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command(argv$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command[1]);platform$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command.setBaseUri(thisProgram$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command);

TypeError: platform$$module$Volumes$Saxonica$src$saxonica$saxon_js_enterprise$src$main$js$nodeJS$command.setBaseUri is not a function at Object. (E:\prod\node_modules\xslt3\xslt3.js:44:590) at Object. (E:\prod\node_modules\xslt3\xslt3.js:93:95) at Module._compile (internal/modules/cjs/loader.js:1063:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10) at Module.load (internal/modules/cjs/loader.js:928:32) at Function.Module._load (internal/modules/cjs/loader.js:769:14) at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:72:12) at internal/main/run_main_module.js:17:47

I looked up the release notes but it does not indicate any issues with backward compatibility.

I did come across the option "relocate" but setting it to "on" resulted in same error. Currently this is causing our build to fail. Any help is much appreciated.


Replies (4)

Please register to reply

RE: Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***) - Added by Debbie Lockett 3 months ago

Apologies for the problems. Please try upgrading your version of the npm package saxon-js to 2.4 as well. (Using different version numbers of the packages xslt3 and saxon-js is not recommended.)

We are investigating the fatal error using SaxonJS 2.3.

Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***) - Added by Norm Tovey-Walsh 3 months ago

Saxonica Developer Community writes:

The transformation was working just fine all this time until today.
Initially the following error was throw:

Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***)
Node.js version v14.16.1

The “no longer supported” message isn’t (by itself) a fatal error. Or at
least it isn’t supposed to be. I just tried compiling a stylesheet with
2.3 and it wasn’t.

Is there any chance that an actual error has crept into your XSLT
transformation? Is there any chance you could provide a test case that
demonstrates the problem?

Upgrading both saxon-js and xslt3 to 2.4.0 will make the “no longer
supported” message go away. But I’d still like to work out what the
fatal error was.

Be seeing you,
norm

--
Norm Tovey-Walsh
Saxonica

RE: Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***) - Added by Deepak Pai 3 months ago

Thanks for your prompt response.

Yes, upgrading both saxon-js and xslt3 to 2.4.0 makes the “no longer supported” message go away.

Having xslt3 on 2.3.0 (using ~2.3.0 in our package.json) installs SaxonJS 2.4.0. This causes the other error "TypeError: platform$$module$...."

However having both on 2.3.0 results in “no longer supported”. So looks like I have to upgrade to 2.4.0.

I doubt the chances of any actual error to have crept into our XSLT as it has been in use for a long time with no changes being made to it.

RE: Fatal error: Saxon-JS 2.3 from Saxonica (*** NO LONGER SUPPORTED ***) - Added by Norm Tovey-Walsh 3 months ago

However having both on 2.3.0 results in “no longer supported”. So
looks like I have to upgrade to 2.4.0.

That message is just supposed to be informative, if it’s actually
causing a fatal error, I’d love to see a test case so I can understand
why. For what it’s worth, I can’t reproduce it and there haven’t been
any other reports of fatal errors, so I imagine it’s somehow related to
a specific detail in your environment.

Anything you can provide that would let me reproduce it would be a big
help.

Be seeing you,
norm

--
Norm Tovey-Walsh
Saxonica

    (1-4/4)

    Please register to reply