Project

Profile

Help

Bug #1735

IndexOutofBounds exception using substring() with non-BMP string

Added by Michael Kay over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XPath conformance
Sprint/Milestone:
-
Start date:
2013-04-23
Due date:
% Done:

100%

Legacy ID:
Applies to branch:
Fix Committed on Branch:
Fixed in Maintenance Release:
Found in version:
9.5
Fixed in version:
9.5.0.2

Description

When substring() is used in 9.5 to access a string containing non-BMP characters, and when the start/length arguments project beyond the end of the string, an IndexOutOfBounds exception occurs,

The problem is new in 9.5. A patch is being committed. Test cases have been added to the W3C test suite.

History

#1 Updated by O'Neil Delpratt over 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.5.0.2

Also available in: Atom PDF