Project

Profile

Help

Bug #2178

NullPointerException in TransformerImpl.setParameter()

Added by Michael Kay almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
JAXP Java API
Sprint/Milestone:
Start date:
2014-10-13
Due date:
% Done:

100%

Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

Raised by David Fonti here:

https://saxonica.plan.io/boards/2/topics/6018

setParameter() throws an NPE if there are no global xsl:param elements in the stylesheet.


Related issues

Duplicated by Saxon - Bug #2185: NullPointerException when setting a parameter value Duplicate 2014-10-16 Actions
Duplicated by Saxon - Bug #2203: NPE in XsltExecutable with 9.6.0-1 Duplicate 2014-10-29 Actions

History

#1 Updated by Michael Kay almost 5 years ago

  • Status changed from New to Resolved
  • Found in version set to 9.6

Patched in the 9.6 and 9.7 branches; test case TraxTest.testExampleSetParam() added to JUnit tests.

#2 Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.6.0.2

Bug fix applied to the maintenance release Saxon 9.6.0.2

#3 Updated by O'Neil Delpratt almost 4 years ago

  • Sprint/Milestone set to 9.6.0.2
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.2 added

Please register to edit this issue

Also available in: Atom PDF