Project

Profile

Help

Bug #2183

Bytecode generation: xs:string returns "" instead of ()

Added by Michael Kay almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XPath conformance
Sprint/Milestone:
Start date:
2014-10-15
Due date:
% Done:

100%

Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

The generated bytecode for an expression such as xs:string(/a/b/c) returns a zero length string instead of an empty sequence when the supplied node-set is empty.

The problem is present in 9.6 and earlier releases.

I have written a number of new W3C QT3 test cases for value comparisons; the problem is revealed by test case value-comp-eq-string-4

History

#1 Updated by Michael Kay almost 5 years ago

  • Status changed from New to Resolved

I have fixed this on the 9.5, 9.6, and 9.7 branches by a patch to AnyTypeToStringConverterCompiler.java

#2 Updated by Michael Kay almost 5 years ago

Turns out the first patch solves the problem on the "compileToPrimitive" path but not on the "compileToItem" path in AnyTypeToStringConverterCompiler. The problem is revealed by the same test, run with option -unfolded. An additional patch is being applied to the same class.

#3 Updated by O'Neil Delpratt almost 5 years ago

Bug fix applied to the Saxon 9.5.1.8 maintenance release.

Saxon 9.6 maintenance release pending

#4 Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.6.0.2

Bug fix applied to the maintenance release Saxon 9.6.0.2

#5 Updated by O'Neil Delpratt almost 4 years ago

  • Sprint/Milestone set to 9.6.0.2
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.2 added

Please register to edit this issue

Also available in: Atom PDF