Project

Profile

Help

Bug #2194

No location information in output pipeline for SAXResult

Added by Michael Kay almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Diagnostics
Sprint/Milestone:
Start date:
2014-10-22
Due date:
% Done:

100%

Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

When transformation output is sent to a SAXResult (or any kind of destination other than a serializer), there is no information available about the locations in the stylesheet that generated each output event. This has several consequences: it can lead to poor diagnostics when errors are detected within the output pipeline (e.g. output validation errors, or writing attributes when there is no open start tag), it prevents debugging tools doing back-mapping from the result document to the stylesheet, and it may mean that the base URI on output documents is not correctly set.

A patch is being applied to the 9.6 and 9.7 branches, in module net.sf.saxon.s9api.XsltTransformer.

The problem was present in earlier releases but only affected applications using the s9api interface; in 9.6 the problem is more noticeable because the JAXP transformer API is now layered on top of s9api.

History

#1 Updated by Michael Kay almost 5 years ago

  • Status changed from New to Resolved

#2 Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.6.0.2

Bug fix applied to the maintenance release Saxon 9.6.0.2

#3 Updated by O'Neil Delpratt almost 4 years ago

  • Sprint/Milestone set to 9.6.0.2
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.2 added

Please register to edit this issue

Also available in: Atom PDF