Project

Profile

Help

Bug #2255

xsl:assert no longer producing message in Saxon-PE 9.6.0.3J

Added by David Sewell over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
XSLT conformance
Sprint/Milestone:
Start date:
2014-12-11
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

Under Saxon-PE 9.5, xsl:assert emitted a message when its test condition failed. 9.6 is no longer producing a message.

For example, given the XML

2

and the XSLT

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="3.0">

<xsl:template match="number">

<xsl:assert test=". eq '1'">The number must be 1!</xsl:assert>

<xsl:copy-of select="."/>

</xsl:template>

</xsl:stylesheet>

Saxon 9.5 sends the message "The number must be 1!" and terminates with an error code; Saxon 9.6 just terminates with error.

History

#1 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from New to In Progress
  • Assignee set to O'Neil Delpratt

Thanks for raising this issue which I have reproduced. Currently investigating.

#2 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from In Progress to Resolved
  • Priority changed from Low to Normal
  • % Done changed from 0 to 100
  • Found in version set to 9.6

Bug fixed and committed to subversion. The cause was a failure to close the writer when the exception is thrown. This we now do in a finally block in the Controller.

#3 Updated by O'Neil Delpratt over 6 years ago

  • Fixed in version set to 9.6.0.4

Bug fix applied in the Saxon 9.6.0.4 maintenance release.

#4 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from Resolved to Closed

#5 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone set to 9.6.0.4
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.4 added

#6 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.4 to 9.6.0.3
  • Fixed in Maintenance Release 9.6.0.3 added
  • Fixed in Maintenance Release deleted (9.6.0.4)

#7 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.3 to 9.6.0.4
  • Fixed in Maintenance Release 9.6.0.4 added
  • Fixed in Maintenance Release deleted (9.6.0.3)

Please register to edit this issue

Also available in: Atom PDF