Project

Profile

Help

Bug #2278

Pattern descendant::text()[1] gives a spurious warning, and no matches

Added by Michael Kay over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XSLT conformance
Sprint/Milestone:
Start date:
2015-01-04
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

When the pattern match="descendant::text()[1]" is used in a template rule, then

(a) there is a spurious warning that "the descendant axis starting at a text node will never select anything"

(b) the pattern never matches anything.

Both effects are caused by an incorrect type inference.

Added to W3C test suite as test case match-236.

History

#1 Updated by Michael Kay over 6 years ago

  • Status changed from New to Resolved

A patch has been committed on the 9.6 and 9.7 branches.

#2 Updated by O'Neil Delpratt over 6 years ago

  • % Done changed from 0 to 100
  • Fixed in version set to 9.6.0.4

Bug fix applied in the Saxon 9.6.0.4 maintenance release.

#3 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from Resolved to Closed

#4 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone set to 9.6.0.4
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.4 added

#5 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.4 to 9.6.0.3
  • Fixed in Maintenance Release 9.6.0.3 added
  • Fixed in Maintenance Release deleted (9.6.0.4)

#6 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.3 to 9.6.0.4
  • Fixed in Maintenance Release 9.6.0.4 added
  • Fixed in Maintenance Release deleted (9.6.0.3)

Please register to edit this issue

Also available in: Atom PDF