Project

Profile

Help

Bug #2286

saxon9-icu jar missing from Saxon-EE 9.6.0.3 release

Added by O'Neil Delpratt over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Build and release
Sprint/Milestone:
Start date:
2015-01-14
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:

Description

The saxon9-icu jar file is missing from the Saxon-EE 9.6.0.3 maintenance release.

The problem is in the build script file. The creation of the jar file is being done in a Saxon-PE related task and then copied to the EE directory. This ordering is suspect to failure due to the order in the task execution.

I am changing this to be less dependent on PE.

History

#1 Updated by O'Neil Delpratt over 6 years ago

Also the saxon-sql.jar file has the same problem.

#2 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from New to Resolved

Bug fixed in the build-j.xml file. I have copied the places where we create the jar files for sql and icu to the jar-eej ant task.

Available in the Saxon 9.6.0.4 maintenance release.

#3 Updated by O'Neil Delpratt over 6 years ago

  • Status changed from Resolved to Closed

#4 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone set to 9.6.0.4
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.4 added

#5 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.4 to 9.6.0.3
  • Fixed in Maintenance Release 9.6.0.3 added
  • Fixed in Maintenance Release deleted (9.6.0.4)

#6 Updated by O'Neil Delpratt over 5 years ago

  • Sprint/Milestone changed from 9.6.0.3 to 9.6.0.4
  • Fixed in Maintenance Release 9.6.0.4 added
  • Fixed in Maintenance Release deleted (9.6.0.3)

Please register to edit this issue

Also available in: Atom PDF