Project

Profile

Help

Bug #2300

closed

Namespace context is lost when inlining an expression containing call to accumulator-before()

Added by Michael Kay over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XSLT conformance
Sprint/Milestone:
Start date:
2015-01-26
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:
Platforms:

Description

When an expression containing a call to accumulator-before() or accumulator-after() is copied, for example because it appears within the initialization of a variable that is inlined, then the static namespace context is lost. The static context, notably the namespace context, is needed to resolve a QName supplied as the first argument of the call.

A patch is being committed on the 9.6 branch. The problem is already fixed in the 9.7 branch.

Actions #1

Updated by Michael Kay over 7 years ago

Test case accumulator-040 created.

Actions #2

Updated by O'Neil Delpratt over 7 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 9.6.0.5

Bug fix applied in the Saxon 9.6.0.5 maintenance release.

Actions #3

Updated by O'Neil Delpratt over 6 years ago

  • Sprint/Milestone set to 9.6.0.5
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.5 added

Please register to edit this issue

Also available in: Atom PDF