Project

Profile

Help

Bug #2305

closed

FactoryConfigurationError: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found

Added by O'Neil Delpratt over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
.NET API
Sprint/Milestone:
Start date:
2015-02-02
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.6
Fix Committed on Branch:
9.6
Fixed in Maintenance Release:
Platforms:

Description

This bug issue was reported in following forum post:

https://saxonica.plan.io/boards/3/topics/5992

The use of the SAXParserFactoryImpl when setting the XMLResolver throws the following exception:

[FactoryConfigurationError: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found]
   IKVM.NativeCode.sun.misc.Unsafe.throwException(Object thisUnsafe, Exception x) +33
   sun.misc.Unsafe.throwException(Exception t) +37
   java.lang.Class.newInstance0(CallerID ) +744
   java.lang.Class.newInstance(CallerID ) +104
   net.sf.saxon.trans.DynamicLoader.getInstance(String className, ClassLoader classLoader) +180
   net.sf.saxon.Configuration.makeURIResolver(String className) +73
   net.sf.saxon.trans.XmlCatalogResolver.setCatalog(String catalog, Configuration config, Boolean isTracing) +237
   _Default.Page_Load(Object sender, EventArgs e)

This is a class loader issue, where the class is not available in the default ClassLoader. The solution in the DynamicLoader class is to add the SAXParserFactoryImpl class to the list of known classes.

Actions #1

Updated by O'Neil Delpratt over 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Bug fixed and committed to subversion. The problem is the IKVM runtime cannot find in which DLL the SAXParserFactoryImpl is located. The fix was to use the assembly type information when setting the system property in the Java code. i.e.:

System.setProperty("javax.xml.parsers.SAXParserFactory", "org.apache.xerces.jaxp.SAXParserFactoryImpl, saxon9ee, Version="+ Version.getProductVersion()+", Culture=neutral, PublicKeyToken=e1fdd002d5083fe6");
Actions #2

Updated by O'Neil Delpratt over 7 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 9.6.0.5

Bug fix applied in the Saxon 9.6.0.5 maintenance release.

Actions #3

Updated by O'Neil Delpratt over 6 years ago

  • Sprint/Milestone set to 9.6.0.5
  • Applies to branch 9.6 added
  • Fix Committed on Branch 9.6 added
  • Fixed in Maintenance Release 9.6.0.5 added

Please register to edit this issue

Also available in: Atom PDF