Project

Profile

Help

Bug #2674

Broken links on Saxon on .NET section in the HTML version of the documentation

Added by O'Neil Delpratt over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Documentation
Sprint/Milestone:
Start date:
2016-03-14
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.7
Fix Committed on Branch:
9.7
Fixed in Maintenance Release:

Description

The HTML version of the documentation contains many broken links on the pages within the section: 'Saxon on .NET' The subpages in question are these:

http://www.saxonica.com/html/documentation/dotnet/dotnetapi.html

http://www.saxonica.com/html/documentation/dotnet/xmlparsing.html

History

#1 Updated by Debbie Lockett over 4 years ago

  • Status changed from New to Resolved
  • Fix Committed on Branch 9.7 added

Fix made in saxon9/to-static/s-body.xsl stylesheet - used for generating HTML version of Saxon documentation from the XML version. Committed to the 9.7 branch (and dev branch for good measure).

Fix ensures that the href attribute for a link in the 'javalink' class is transformed to point to the correct API documentation: i.e. in the case that the class name begins with 'Saxon.Api' then the new link begins with 'dotnetdoc/' rather than 'javadoc/'.

Various affected sections of the online HTML documentation have been updated to correct the links (not only the dotnet section, but also source-docs, configuration, schema-processing, extensibility).

#2 Updated by O'Neil Delpratt over 4 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 9.7.0.5 added

Bug fix applied in the Saxon 9.7.0.5 maintenance release.

#3 Updated by O'Neil Delpratt over 4 years ago

  • Sprint/Milestone set to 9.7.0.5

Please register to edit this issue

Also available in: Atom PDF