Project

Profile

Help

Support #2684

Saxon/C is contantly crashing an PHP crashes with it

Added by Philipp F over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Start date:
2016-03-21
Due date:
% Done:

0%

Estimated time:
Found in version:
Saxon/C 1.0.0

Description

Hi, unfortunately I deperately need your help again!

I have installed Saxon/C on two similar machines now, and have the same problem on both: Saxon/C 1.0.0 is constantly crashing. From time to time it works but in most cases it crashes. From time to times it works fine, but in most cases it crashes. The more complex the Stylesheets are, the more often it crashes. But it even happens with very very simple stylesheets from time to time. I really have no Idea why that is happening and would absolutely appreaciate your help

Also it can maybe count as a bug, that, when the Saxon (or Jet) crashes, that the execution of the whole PHP Script stops. I do not get any error but a broken connection because the PHP execution fails completely.

In the error.log I find the following:

JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00007fad4cba8959
Please, contact the vendor of the application.
Extra information about error is saved in the "jet_err_14392.txt" file. 

Fatal Error: Crash during termination.

I attach the mentioned file. Being just a PHP Developer I can not make the slightest use of it unfortunately.

System information:

  1. Architecture: x86_64

  2. OS: Debian 8.3

  3. Kernel: Linux version 3.16.0-4-amd64 (gcc version 4.8.4 (Debian 4.8.4-1) )

  4. Apache: Apache/2.4.10 (Debian)

  5. PHP 5.6.17-0+deb8u1

  6. PHP API => 20131106

  7. PHP Extension => 20131226

  8. Zend Extension => 220131226

  9. Zend Extension Build => API220131226,NTS

  10. PHP Extension Build => API20131226,NTS

I am completely stuck with this and thank you in advance for your support.

jet_err_14392.txt (63.9 KB) jet_err_14392.txt Philipp F, 2016-03-21 17:01

History

#1 Updated by O'Neil Delpratt over 4 years ago

Thanks for reporting the problem you have found. Please see the bug which I believe is a duplicate of your issue:

https://saxonica.plan.io/issues/2670

I have managed to fix it and just in the process of testing. I will submit a patch shortly which you can use to rebuild the Saxon/C PHP module.

I will releasing a maintenance release this week as we have fixed a number of bugs iincluding this one which is critical.

Thanks again for your feedback.

#2 Updated by Philipp F over 4 years ago

No, this is not my issue. You have more then one user apparently :)

I also read the other issue before but it seems to be something else, because I don't have SElInux enabled. At least I have no sestatus command, no /etc/sestatus.conf etc.

#4 Updated by Philipp F over 4 years ago

That helped!

#5 Updated by Philipp F over 4 years ago

If you ever come to Berlin, I owe you one beer at least.

#6 Updated by O'Neil Delpratt over 4 years ago

  • Status changed from New to Duplicate

Noted with thanks. We are always interested to know about the projects that include Saxon products. If possible please let us know a little about your project involving Saxon/C - maybe by private email.

Please register to edit this issue

Also available in: Atom PDF