Project

Profile

Help

Bug #2690

saxon.so file missing from 64-bit version and wrong library reference in config.m4

Added by Claudia Nölker about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
PHP Build
Start date:
2016-03-31
Due date:
% Done:

100%

Estimated time:
0:15 h
Found in version:
1.0.0
Fixed in version:
1.0.1

Description

Hello,
the documentation states:
"A built php extension module is included in the directory 'php-library-module'. See the file saxon.so, which was built on a Ubuntu machine with PHP 5.5.9."
However, after installing from file libsaxon-HEC-setup64-v1.0.0.zip, no such directory 'php-library-module' and no such file is available.

Compiling (PHP5.5.33 on OpenSuSE) results in an error:
/bin/sh /opt/Saxonica/Saxon-HEC1.0.0/Saxon.C.API/libtool --mode=link cc -DPHP_ATOM_INC -I/opt/Saxonica/Saxon-HEC1.0.0/Saxon.C.API/include -I/opt/Saxonica/Saxon-HEC1.0.0/Saxon.C.API/main -I/opt/Saxonica/Saxon-HEC1.0.0/Saxon.C.API -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -o saxon.la -export-dynamic -avoid-version -prefer-pic -module -rpath /opt/Saxonica/Saxon-HEC1.0.0/Saxon.C.API/modules php_saxon.lo SaxonProcessor.lo XQueryProcessor.lo XsltProcessor.lo XPathProcessor.lo SchemaValidator.lo XdmValue.lo XdmItem.lo XdmNode.lo XdmAtomicValue.lo SaxonCGlue.lo SaxonCProcessor.lo SaxonCXPath.lo -lstdc++ -lsaxon -ldl
libtool: link: cc -shared -fPIC -DPIC .libs/php_saxon.o .libs/SaxonProcessor.o .libs/XQueryProcessor.o .libs/XsltProcessor.o .libs/XPathProcessor.o .libs/SchemaValidator.o .libs/XdmValue.o .libs/XdmItem.o .libs/XdmNode.o .libs/XdmAtomicValue.o .libs/SaxonCGlue.o .libs/SaxonCProcessor.o .libs/SaxonCXPath.o -lstdc++ -lsaxon -ldl -O2 -Wl,-soname -Wl,saxon.so -o .libs/saxon.so
/usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: cannot find -lsaxon

In the 'Files' section, I found a saxon.so file, however, this is compiled for a 32bit system and therefore not usable:
'wrong ELF class: ELFCLASS32'

Please, where can I get the file saxon.so for a 64bit system?

Claudia


Related issues

Duplicated by Saxon/C - Bug #2697: on Ubuntu make command gives error Rejected 2016-04-05 Actions

History

#1 Updated by O'Neil Delpratt about 2 years ago

  • Category changed from Saxon-C Internals to PHP Build
  • Status changed from New to In Progress
  • Found in version set to 1.0.0

Hi,

Thanks for reporting about the missing file in the 64-bit build. I am in the process of doing a maintenance release so I will add the php module.

What is interesting to me is the failure to build the php module on your SuSE machine. I assume you have followed the steps to install Saxon/C (See: http://www.saxonica.com/saxon-c/index.xml#installing). I think the root cause of your PHP build problems is in the wrong library filename for Saxon/C referenced in the config.m4. Please check against this version: https://dev.saxonica.com/repos/archive/opensource/latest9.6/hec/Saxon.C.API/HEC/config.m4
You can just replace the file.

If you have any more problems please don't hesitate to get back in touch.

#2 Updated by Claudia Nölker about 2 years ago

Hi,
thanks a lot for the fast response.
Yes, I have basically followed those steps, and used the install.sh script. I had to adjust this a bit because the package names differ ('php5-devel' is necessary) and the paths to the configuration files for Apache2 and PHP5 are different.

After replacing the referenced file, the install script finished with success. :-)
And my phpinfo.php file tells me:
Saxon/C EXT version 1.0.0
Saxon-HEJ 9.6.0.8
Excelsior JET 11 MP1

Okay, then, I am ready to start.

Thanks again,
Claudia

#3 Updated by O'Neil Delpratt about 2 years ago

Great thanks for letting us know.

#4 Updated by O'Neil Delpratt about 2 years ago

  • Subject changed from saxon.so file missing to saxon.so file missing from 64-bit version and wrong library reference in config.m4

#5 Updated by O'Neil Delpratt about 2 years ago

  • Tracker changed from Support to Bug
  • % Done changed from 0 to 100

#6 Updated by O'Neil Delpratt about 2 years ago

  • Status changed from In Progress to Resolved

#7 Updated by O'Neil Delpratt about 2 years ago

  • Duplicated by Bug #2697: on Ubuntu make command gives error added

#8 Updated by O'Neil Delpratt about 2 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 1.0.1

Bug fix applied in the Saxon/C 1.0.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF