Bug #2752


JS: nashorn references in core (browser) code

Added by John Lumley almost 8 years ago. Updated over 6 years ago.

Start date:
Due date:
% Done:


Estimated time:
Applies to JS Branch:
Fix Committed on JS Branch:
Fixed in JS Release:
SEF Generated with:
Contact person:
Additional contact persons:


Domutuils.copyItem()#81 refers to @cloneNode()@, which is defined in @nashorn/xmldom/dom.js@. When running under a browser nashorn is not loaded, and if so would probably produce conflict as it use node constructors.

Will investigate further.

Actions #1

Updated by Debbie Lockett almost 8 years ago

I'm aware of this issue with Node.cloneNode() too, but haven't worked out a solution yet. The browser DOM version of Node does have a cloneNode() method but it takes one argument. The nashorn version we're using takes 3 arguments, and does a bit more in setting the parent document (if I remember correctly). I was hoping to make a change to just use the one arg version for any platform (browser or nashorn or whatever), but haven't quite worked out how to do that/ where changes are needed.

Actions #2

Updated by Michael Kay over 7 years ago

  • Project changed from 4 to SaxonJS
Actions #3

Updated by Debbie Lockett over 7 years ago

  • Status changed from New to Resolved

Closing, since these issues were actually resolved before the Saxon-JS 0.9 beta release. Note that:

  1. in a number of places the use of Node.cloneNode() was replaced by Document.importNode() since this was actually better

  2. since this bug was raised, we added checks on the platform (i.e. in browser or not) where relevant to allow for DOM differences, etc.

Actions #4

Updated by Debbie Lockett about 7 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Found in version changed from 9.8 to 0.9
  • Fixed in version set to 0.9.1

Bug fix applied in the Saxon-JS 0.9.1 beta release.

Actions #5

Updated by Community Admin over 6 years ago

  • Fixed in JS Release set to Saxon-JS 0.9.1
  • Applies to JS Branch 0.9 added
  • Fix Committed on JS Branch 0.9 added
Actions #6

Updated by Debbie Lockett over 6 years ago

  • Fixed in JS Release changed from Saxon-JS 0.9.1 to Saxon-JS 0.9.0

Please register to edit this issue

Also available in: Atom PDF Tracking page