Project

Profile

Help

Bug #2833

closed

JS: anomalous descendant behaviour under ixsl:page()

Added by John Lumley over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Category:
-
Sprint/Milestone:
-
Start date:
2016-07-12
Due date:
% Done:

0%

Estimated time:
Applies to JS Branch:
0.9
Fix Committed on JS Branch:
0.9
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

When using the XPath ixsl:page()//*[@id = $tests] ($tests bound to a simple string) no nodes are returned, whereas ixsl:page()//*[@id = 'QT3-tests']//*[@id = $tests] does return the intended node (which are all descendants of #QT3-tests).

Running under Firefox. Will try to distill an example.

Actions #1

Updated by Michael Kay over 7 years ago

  • Project changed from 4 to SaxonJS
Actions #2

Updated by Debbie Lockett over 7 years ago

I have not been able to reproduce the problem. Do you still see it happening? If so, could you direct me to where it occurs, or produce another example?

Actions #3

Updated by John Lumley about 7 years ago

  • Status changed from New to Closed

Unable to reproduce in present configuration - assume now working correctly.

Actions #4

Updated by Debbie Lockett over 6 years ago

  • Fixed in JS Release set to Saxon-JS 0.9.1
  • Applies to JS Branch 0.9 added
  • Fix Committed on JS Branch 0.9 added

Assumed fixed in Saxon-JS 0.9.1 release.

Please register to edit this issue

Also available in: Atom PDF Tracking page