Project

Profile

Help

Bug #3413

closed

Test accumulator-014 fails "Invalid local name"

Added by Michael Kay almost 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XSLT Conformance
Sprint/Milestone:
-
Start date:
2017-08-28
Due date:
% Done:

100%

Estimated time:
Applies to JS Branch:
1.0, Trunk
Fix Committed on JS Branch:
Trunk
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

This test uses an accumulator name "figNr" and fails with an error saying the local name "" is invalid. Also, the line number is given but the system ID is null in the error message.

Actions #1

Updated by Michael Kay almost 7 years ago

The problem is that when the accumulator rule attempts to access the global parameter $increment, the component reference is not being resolved correctly, probably because the current component in the context has not been updated to be the accumulator.

Actions #2

Updated by Michael Kay over 6 years ago

  • Priority changed from Low to Normal

I have committed a fix so that accumulator-014 now works. The change is to Accum.js, where applyRule() now sets the current component, using a new function makeComp.

I'll leave the bug open as a catch-all for other tests in the accumulator test set that are still failing.

Actions #3

Updated by Michael Kay over 6 years ago

We are currently failing the following accumulator tests [for the given reasons]

  accumulator-034 [xsl:global-context-item not implemented]
  accumulator-039 [wrong results]
  accumulator-041 [wrong results]
  accumulator-043 [crashes in isConstrainedMap()]
  accumulator-052a [another component binding issue, this time in  @initial-value]
  accumulator-052b [ditto]
  accumulator-053 [crashes in isConstrainedMap()]
  accumulator-054 [ditto]
  accumulator-056 [component binding in @initial-value]
  accumulator-065 [Saxon-JS does not support higher-order functions - dependency missing from test]
  accumulator-068 [Fails "xsl:stream is not supported in Saxon-JS"]
Actions #4

Updated by Michael Kay over 6 years ago

Committed a further patch to fix the context (especially the current component) for evaluating the initial-value.

Failing tests are now:

accumulator-034

accumulator-041

accumulator-043

accumulator-053

accumulator-054

accumulator-065

accumulator-068

Actions #5

Updated by Michael Kay over 6 years ago

  • Status changed from New to Resolved

The crash in isConstrainedMap() occurs only with ADVANCED_OPTIMIZATIONS enabled in Closure compiler. It is caused by the HashTrie.conforms() method being written as "conforms" in quotes. I've changed the name to be unquoted, though I think this may clash with changes made by John. With this change, the test failures are now:

accumulator-034

accumulator-041

accumulator-065

accumulator-068

Fixed -065 and -068 by adding a suitable dependency to the test.

-034 is a known limitation (global-context-item)

-041 uses the regular expression \W which is failing as a result of bug #3387.

So I shall commit the "conforms" change, and close this bug.

Actions #6

Updated by Debbie Lockett over 6 years ago

  • Applies to JS Branch 1.0, Trunk added
  • Fix Committed on JS Branch Trunk added
Actions #7

Updated by Debbie Lockett almost 4 years ago

  • Description updated (diff)
  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 2.0
Actions #8

Updated by Debbie Lockett almost 4 years ago

  • Category set to XSLT Conformance

Please register to edit this issue

Also available in: Atom PDF Tracking page