Project

Profile

Help

Bug #3847

closed

Unable to load /usr/local/lib/libsaxonpec.dylib on Mac OSX

Added by O'Neil Delpratt over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
JET
Start date:
2018-07-17
Due date:
% Done:

100%

Estimated time:
Found in version:
1.1.0
Fixed in version:
1.1.2
Platforms:

Description

Error reported by user when running the Saxon/C cppTest samples:

Unable to load /usr/local/lib/libsaxonpec.dylib

Investigation:

Mac OSX: 10.10: Samples run successfully

Mac OSX 10.13.5: Reproduced the same error above

I have reported this issue to Excelsior Jet that the Jet executables fails under Mac OSX 10.13 versions and above.

Actions #1

Updated by O'Neil Delpratt over 5 years ago

Response from Excelsior:

This  issue has been fixed for the next version of Excelsior JET (Fall 2018). We will notify you as it's out.

This means that Saxon/C is not yet compatible with Mac OS X version 10.13.X until the next release of Jet is available.

Actions #2

Updated by Michael Heins almost 5 years ago

Is there any update on this issue?

Actions #3

Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from AwaitingInfo to In Progress

Update:

Excelsior Jet version 15.3 was released in November 2018 which covers MoJave. I am in the progress of doing a maintenance release. If you would like to use it straight away you can download the latest C/C++ code and I will make available the libsaxonhec.dylib later today if you like?

Actions #4

Updated by O'Neil Delpratt almost 5 years ago

Update:

We are still experiencing problems with the Saxon/C library on Mojave.

Error:

Unable to load /usr/local/lib/libsaxoneec.dylib
Error: : No such file or directory

I have reported this to excelsior Jet which they are investigating . Message from Excelsior Jet:

We had a similar issue in Excelsior JET 15.0 caused by undocumented specifics of macOS High Sierra which was fixed.
So there is a chance that macOS Mojave introduced some new hidden requirements for their binary format which we have to support.

They have the Saxon/C library with an executable to help with investigations.

Actions #5

Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Bug fixed.

I confirm that the library created with Jet 15.3 works on Mojave.

Working on getting the release out.

Actions #6

Updated by O'Neil Delpratt almost 5 years ago

  • Status changed from Resolved to Closed
  • Fixed in version set to 1.1.2

Bug fix applied in the Saxon/C 1.1.2 maintenance release.

Please register to edit this issue

Also available in: Atom PDF