Project

Profile

Help

Bug #4030

Saxon-HE/C 64-bit Linux setup binary didn't install PHP5-Build folder

Added by Christina Spies over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
PHP Build
Start date:
2018-11-15
Due date:
% Done:

0%

Estimated time:
Found in version:
1.1.0
Fixed in version:
1.1.2

Description

Using the 64-bit Linux binary from this page - http://www.saxonica.com/download/c.xml - I was trying to build Saxon-HE/C v1.1.0 as an extension for PHP 5.6.38.

This page - http://www.saxonica.com/saxon-c/doc/html/index.html - says:

For PHP5 please copy files in the PHP5-Build directory into the Saxon.C.API directory.

But, on my computer, the installer didn't create that folder. I searched the web to try to find some solutions, and found 1 web page which mentioned the same problem:

https://serverpilot.io/docs/how-to-install-the-php-saxon-c-extension

Installing Saxon/C on PHP 5

According to the official documentation, "for PHP5 please copy files in the PHP5-Build directory into the Saxon.C.API directory." However, there is no PHP5-Build directory provided. Please contact Saxonica's support for assistance with building for PHP 5.

Earlier this year, using the 32-bit installer, I was successfully able to build Saxon-HE/C v1.1.0 as an extension for PHP 5.6.13 in a 32-bit Puppy Linux system (running in VirtualBox), since the PHP5-Build folder was present.

So, perhaps the 64-bit installer has a glitch which stops it from creating that folder, and perhaps other files, such as the Readme, which also was surprisingly missing when I ran the installer in my non-VirtualBoxed 64-bit Puppy Linux system.

I've attached my entire install.log file.

Thanks for any help! Also, thank you so much for creating Saxon/C, and for all the other wonderful work you do!

install.log (63.4 KB) install.log Christina Spies, 2018-11-16 00:15

History

#1 Updated by Michael Kay over 1 year ago

  • Project changed from Saxon to Saxon/C
  • Category set to PHP Build
  • Assignee set to O'Neil Delpratt

#2 Updated by O'Neil Delpratt over 1 year ago

  • Status changed from New to In Progress
  • Priority changed from Low to Normal
  • Found in version set to 1.1.0

Hi,

Thanks for reporting this. Looking at the Saxon-HE/C version we also seem to be missing the built php library for PHP5 and there is a bug in the config.m4 for PHP5 as it references php7_saxon.cpp, instead it should be referencing php5_saxon.cpp. I have now fixed in the svn repository.

In the downloads for Saxon-EE/C and Saxon-PE/C we have both the files for PHP5 and the built library for PHP5 and PHP7.

I will look to make sure all the documented files are in the download.

As a workaround you can download the PHP5 files here:

PHP5-Build: download config.m4

Under svn in the Saxon-C-API directory download the files: php5_saxon.h php5_saxon.cpp

#3 Updated by Christina Spies over 1 year ago

The workaround worked perfectly! Thank you so much!

#4 Updated by O'Neil Delpratt over 1 year ago

  • Status changed from In Progress to Closed
  • Fixed in version set to 1.1.2

This bug was fixed in the Saxon/C maintenance release 1.1.2.

Please register to edit this issue

Also available in: Atom PDF