Project

Profile

Help

Bug #4096

closed

EQName syntax in xsl:strip-space

Added by Michael Kay over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XSLT conformance
Sprint/Milestone:
-
Start date:
2019-01-15
Due date:
% Done:

0%

Estimated time:
Legacy ID:
Applies to branch:
9.9, trunk
Fix Committed on Branch:
9.9, trunk
Fixed in Maintenance Release:
Platforms:

Description

It looks as if a stylesheet specifying *:x or x:* in an xsl:strip-space or xsl:preserve-space declaration will fail on import. The value is serialized as Q{uri}* or *:x respectively, but the package loader attempts to parse the value as an ItemType (which it is not).

Test merge-002 uses xsl:strip-space elements="*". XJ exports this as element() and succeeds in importing this using parseItemType(). But XX exports it as *, which is not accepted. I haven't found any tests using *:x or x:*.

Actions #1

Updated by Michael Kay over 3 years ago

Temporary and partial fix: I've changed the package loader to accept * as the value (meaning all elements)

Actions #2

Updated by Michael Kay over 3 years ago

  • Subject changed from Export/Import of a stylesheet with xsl:strip-space elements="*:x" or "x:*" to EQName syntax in xsl:strip-space
  • Category changed from XSLT export to XSLT conformance

The problem is wider than I realised. xsl:strip-space (and preserve-space) do not handle any variant of the new EQName syntax at all, regardless of export/import.

Actions #3

Updated by Michael Kay over 3 years ago

  • Status changed from New to Resolved
  • Applies to branch 9.9, trunk added
  • Fix Committed on Branch 9.9, trunk added
  • Fixed in Maintenance Release 9.6.0.3 added

Fixed on 9.9 branch and trunk.

Added a number of new test cases to the strip-space test set.

Actions #4

Updated by O'Neil Delpratt about 3 years ago

  • Status changed from Resolved to Closed
  • Fixed in Maintenance Release 9.9.1.1 added
  • Fixed in Maintenance Release deleted (9.6.0.3)

Bug fix applied in the Saxon 9.9.1.1 maintenance release

Please register to edit this issue

Also available in: Atom PDF