Project

Profile

Help

Bug #4126

closed

MetaTagAdjuster replicates namespace bindings

Added by Michael Kay over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
2019-02-01
Due date:
% Done:

100%

Estimated time:
Legacy ID:
Applies to branch:
9.9, trunk
Fix Committed on Branch:
9.9, trunk
Fixed in Maintenance Release:
Platforms:

Description

The MetaTagAdjuster (used on the HTML serialization pipeline) contains the logic

for (NamespaceBinding ns : namespaceBindings) {
            if (inMetaTag) {
                namespaces.add(ns);
            } else {
                nextReceiver.namespace(namespaceBindings, properties);
            }
        }

which is clearly wrong when namespaceBindings contains more than one namespace; in line 5 namespaceBindings should be ns. We're only getting away with this because most paths send namespaces down the pipeline one at a time. Failure observed when we change that on the development branch.

Actions #1

Updated by Michael Kay over 3 years ago

A similar error appears in StartTagBuffer.namespace()

Actions #2

Updated by Michael Kay over 3 years ago

  • Status changed from New to Resolved
  • Priority changed from Low to Normal
  • Applies to branch 9.9, trunk added
  • Fix Committed on Branch 9.9, trunk added

Fixed these obvious code errors; relying on standard regression tests to pick up any problems.

Actions #3

Updated by O'Neil Delpratt about 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in Maintenance Release 9.9.1.2 added

Bug issue fixed in the Saxon 9.9.1.2 maintenance release.

Please register to edit this issue

Also available in: Atom PDF