Project

Profile

Help

Bug #4271

Saxon/C extension installation at Ubuntu 16.04 dont works!

Added by Denis Jurkovsek about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Category:
Linux
Start date:
2019-08-06
Due date:
% Done:

0%

Found in version:
1.1.2
Fixed in version:

Description

Hello,

i install saxon/c php extension on ubuntu 16.04 with php 5.6. All works fine to the make step, after i run the make command, i get this error: ~~~ Makefile:194: recipe for target 'php5_saxon.lo' failed ~~~ i have replaced the PHP5 config.m4 with the default.


Related issues

Related to Saxon/C - Bug #4151: support of compileFromStringAndSave / compileFromFileAndSave + PHP5 build Resolved 2019-03-05 Actions

History

#1 Updated by O'Neil Delpratt about 1 month ago

  • Project changed from Saxon to Saxon/C
  • Category set to Linux
  • Assignee set to O'Neil Delpratt

Thanks for reporting your issue. Investigating it now.

#2 Updated by O'Neil Delpratt about 1 month ago

  • Tracker changed from Support to Bug
  • Status changed from New to AwaitingInfo
  • Found in version set to 1.1.2

This bug issue is related to the issue #4151. The call to the method getUnderlyingValue() should take not arguments

On line 836 of the file php5_saxon.cpp please replace:

obj = ooth->xdmNode->getUnderlyingValue(NULL);

With the following:

obj = ooth->xdmNode->getUnderlyingValue();

Alternatively you can download the following file which contains the fix:

php5_saxon.cpp

#3 Updated by O'Neil Delpratt about 1 month ago

  • Related to Bug #4151: support of compileFromStringAndSave / compileFromFileAndSave + PHP5 build added

#4 Updated by Denis Jurkovsek about 1 month ago

I have replaced this line and maked the phpize and configure again, but it stills shows the error. Must i make some more to?

#5 Updated by O'Neil Delpratt about 1 month ago

Hi,

Summary of the problem as discussed on stackoverflow:

The issue is that the PHP7-dev is installed on the linux machine therefore phpize is building for PHP7. The user has the PHP5 server installed but not the PHP5-dev for building extensions. I have suggested to install PHP5-dev on the machine which comes with phpize5 and then it will be possible to build Saxon/C for PHP5.

Alternatively, I have built the Saxon/C PHP5 library myself and committed it to the following place to download and copy to the directory '/usr/lib/php5/20121212/':

Library Saxon/C for PHP5

#6 Updated by O'Neil Delpratt about 1 month ago

  • Status changed from AwaitingInfo to Rejected

This issue has been resolved by the user. See: https://stackoverflow.com/questions/57371074/why-apache-dont-activate-saxon-c-extension

Therefore I am marking this issue as 'Rejected'.

Please register to edit this issue

Also available in: Atom PDF