Project

Profile

Help

Bug #4387

closed

set_context() takes exactly 0 positional arguments (1 given)

Added by O'Neil Delpratt over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Python
Start date:
2019-11-15
Due date:
% Done:

100%

Estimated time:
Found in version:
1.2.1
Fixed in version:
11.1
Platforms:

Description

Reported in the forum post: https://saxonica.plan.io/boards/4/topics/7679

The use of the keyword argument input_file_name fails to be recognized in run_query_to_string(input_file_name of an PyXQueryProcessor and that causes an exception:

  File "saxonc.pyx", line 2398, in saxonc.PyXQueryProcessor.run_query_to_string
    self.set_context(kwds["input_file_name"])
TypeError: set_context() takes exactly 0 positional arguments (1 given)

The issue is the the file_name keyword is missing from the call to set_context function in run_query_to_string.

Actions #1

Updated by O'Neil Delpratt over 4 years ago

  • Status changed from New to Resolved

Bug fixed in the file saxonc.pyx and committed to subversion

Actions #2

Updated by O'Neil Delpratt over 2 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 11.1

Bug fix patched in SaxonC 11.1 release

Please register to edit this issue

Also available in: Atom PDF