Project

Profile

Help

Bug #4781

closed

Higher-order functions: No failure reported when supplied function doesn't match required signature

Added by Michael Kay over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XPath Conformance
Sprint/Milestone:
-
Start date:
2020-10-05
Due date:
% Done:

100%

Estimated time:
Applies to JS Branch:
2
Fix Committed on JS Branch:
2
Fixed in JS Release:
SEF Generated with:
Platforms:
Company:
-
Contact person:
-
Additional contact persons:
-

Description

XSLT3 Test case higher-order-functions-060 is failing. No error is reported when the function fn:string-length#1 is passed to an argument whose expected type is function(xs:string) as xs:string.

The cause of the problem is that the evaluate() method of XdmFunction.CoercedFunction checks and converts the supplied arguments, but applies no checking to the result.

Actions #1

Updated by Michael Kay over 3 years ago

  • Subject changed from Higher-order functions: No failure reported when supplied function does match required signature to Higher-order functions: No failure reported when supplied function doesn't match required signature
  • Status changed from New to Resolved
  • Applies to JS Branch 2.0, Trunk added
  • Fix Committed on JS Branch 2.0, Trunk added

Fixed in CoercedFunction.evaluate()

Actions #2

Updated by Community Admin about 3 years ago

  • Applies to JS Branch 2 added
  • Applies to JS Branch deleted (2.0, Trunk)
Actions #3

Updated by Community Admin about 3 years ago

  • Fix Committed on JS Branch 2 added
  • Fix Committed on JS Branch deleted (2.0, Trunk)
Actions #4

Updated by Debbie Lockett almost 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in JS Release set to Saxon-JS 2.1

Bug fix applied in the Saxon-JS 2.1 maintenance release.

Please register to edit this issue

Also available in: Atom PDF Tracking page