Project

Profile

Help

Bug #5030

closed

_0 namespace created from User Extension function

Added by O'Neil Delpratt almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
PHP Extension function
Start date:
2021-06-28
Due date:
% Done:

100%

Estimated time:
Found in version:
1.2.1
Fixed in version:
11.1
Platforms:

Description

Reported by user issues with the PHP extension mechanism:

  • It gives an XML tree where node names are not the ones the PHP extension returned
  • with a _0 namespace that we have no idea where it comes from
  • XML tree nodes are existing keywords in our XSL, such as other node names or property names, but they are not related to the data that is manipulated by the extension...
Actions #1

Updated by O'Neil Delpratt almost 3 years ago

The issue is the XdmNode created in the user extension function is from a different SaxonProcessor used in the main PHP program.

Although this is a user issue I have created this bug issue as we can do better in detecting and reporting when a user uses an XdmNode object created from another SaxonProcessor.

Actions #2

Updated by O'Neil Delpratt almost 3 years ago

  • Status changed from New to In Progress

Bug fixed in the NativeCall class. For the case where the extension function returns XdmNode type I have added a a check for compatible configuration.

Leaving bug issue open until fully tested.

Actions #3

Updated by O'Neil Delpratt over 2 years ago

  • Status changed from In Progress to Resolved

Bug fixed in SaxonC 11.

Actions #4

Updated by O'Neil Delpratt over 2 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Fixed in version set to 11.1

Bug fix patched in SaxonC 11.1 release

Please register to edit this issue

Also available in: Atom PDF